Running issue

yes exactly bro.

I have used Excel App Scope many times, in diff workflow, so I have to give the delay before every Excel Scope.

you will get all the excel related processes running and kill them

Here is the screenshot to kill all the process while looping. Check the process name, if it is excel, then kill it

1 Like

Got it the reason is as you have got lot of excel application scope this happens
Even while running it will come to foreground but gets stopped in task bar level itself (you could even notice that)
Fine try with delay before all excel application scope
Cheers @balkishan

1 Like

Yes I can see on the Task Bar excel opening and closing…

But not on the screen as I run the individual workflow…

1 Like

Is 3 sec delay okay ? or more.

If I give more delay it will increase the running time.

Yah that’s why
I hope Three is enough
Let’s try
Cheers @balkishan

1 Like

sure I am trying and let you know.

same issue, Not worked after giving the 3 seconds delay before all Excel Scope.

The process is working fine, but it’s showing the excel in the task bar only not in foreground!

Hi @Pablito @loginerror @Lahiru.Fernando due you know the reason behind this issue?

If run the individual process that time I can see my excel opening in foreground and feeding the data into template I can see clearly. Mostly I have workflow which are related to the Excel activities.

But when I invoked the all workflow in Main. And run the main sometime I can see the Excel opening and feeding template on the screen, sometime on task bar.

So I give delay also before Excel Scope but not worked.

If you know any specific reason behind this, please tell.

My process is working fine if it’s processing the excel in background or foreground.
But I want to see the excel activities in foreground.
Kindly reply…

Hi @balkishan,
What about Click activity on excel in the taskbar to activate application? Or Maximize Window activity?

1 Like

@Palaniyappan knows what I want ?

When I run the whole project I want to see all excel application, opening, extracting data then feed into the template. I want to see on the desktop screen. not it just running in the background.

Now when I run the project sometime it’s running in the background only I can see on the taskbar that excel opening, closing and processing not in foreground.

Just give a try like, inside the excel application scope, use delay as the first activity and give some time like 5 seconds and check @balkishan

1 Like

you say like this.
image

Yes, exactly. Which will stop the execution of next activities for 5 seconds which will show the excel on screen

1 Like

Okay let me try then let you know

Sure @balkishan :slight_smile:

But Can you let me know why you want the excel to be visible?

1 Like

I want to show the customer how uipath working, bcz they don’t know how it’s happening.
If it will run in background then they will not understand how rpa is working and all.

Tried bro, not working only I can see the excel on the tab bar.

yeah, I understand a bit now, then try the same as , whatever the process you have in the excel application scope, between every activity, use delay activity. Make sure the visible activity is checked @balkishan

1 Like

I did for all Excel Scope bro, not for a single scope. And in all Excel Scope the Visible option is checked.

But as I told, sometime it’s visible and sometime not.

But if we run individual then it’s show on the screen.

Can you try the above @balkishan? May be the last try we can do

1 Like