Running IE as different user, unable to identify the opened browser or elements

Hi all,

I have opened IE and run it as a different user that is different from the logged in windows account.
If I were to open the website in a normal IE not using the different user, I am able to identify all elements and select them.
However, after opening as a different user, Uipath is unable to identify the browser session(with either attach browser or window), and the screen elements that could be recognised previously can no longer be identified.
I believe this is due to the process belonging to a different user? Does anybody know any ways in which the session can be selected?

Edit: Fixed. Changed internet settings to prompt for username and password in local intranet zone, which solved the issue. Selectors are fine now.

It has nothing to do with selectors. In fact the website does’t offer any selectors, its one blue screen when you try to indicate any selectors.

But when I open the page normally (meaning not running Internet explorer as a different user), all the elements are selectable and work fine.

@blueleaf I think you are looking for this AttachBrowser.xaml (8.5 KB)

I think a closer indication of my problem is, open a normal browser session, then open the same website as administrator. Then try to indicate a normal click activity inside uipath on both browsers.

@blueleaf open browser and create one variable assume v1 and use attach browser and pass variable v1 here

@indra I am using command prompt to open the IE session as a different user, I am not using the normal open browser. Is there any other way to output a certain browser session as a variable?

Is there any update on the above? I recently encountered the same issue.

I tried to open an internet explorer as a diffrent user (with Powershell) and UiPath does not recognize any internal selector. It only recognizes browser window.

Basically, if your network auto-logins with your default account credentials on that webpage, go to IE settings>Security>local intranet>custom level and scroll all the way to the very end. Enable the “prompt for user name and password”.
Then open the website in uipath as per normal for other processes. Cater for the login window and your workflow should be as per normal from now on.

1 Like

Thanks, this resolves my issue.
Process works under original User name, but the browser authenticates with different user.

I’m having the same problem. The issue is if you use a Bat file Powershell or RunAs from CMD to load up IE, your selectors are from the parent process as the logged on user and IE is running as a different process hence why it figures the whole of IE is just one element within the powershell/cmd/runas. You need to run IE first and challenge for the AD account then.

Hi guys! The thing is, if we change IE options in order to prompt for user name and password, we’ll be messing with the all the other robot processes already running in the same machine. Is there any other way to run an app with different credentials and keeping the selectors?

It’s not ideal but you could change one of the security zones within IE to include your URL as a trusted site and therefore treats it differently.
The problem is IE needs to start up with different credentials or challenge. Alternatively UIPath needs to be able to attach to the child process if you do a RunAs.