Run Unattended Robot Using Community Edition In Locked Virtual Machine

Hello, I am using the community version of UiPath and want to know how can I run my robots unattendedly on the virtual machines that are locked by default if there are no open RDP sessions. Right now my robot is working fine when the RDP connection is opened but when I try running it by closing the RDP it fails with error - Timeout reached. I did a couple of research and find things like the Login To Console Settings (Already done) and Running UiPath in service mode. When I am installing ‘UiPathStudioCommunity.msi’, I am not getting any options to install it in service mode. When I read the below link, it explains that for running the automations unattendedly we need to install ‘UiPathStudio.msi’ but in my orchestrator I am only able to download ‘UiPathStudioCommunity.msi’.

Link -

Thanks for you response in advance.


Ideally community bots cannot be installed in service mode…only enterprise can be installed

One thing you can try is custom install option on community then you might get service mode installation

If you want to run in minimized try this


Hi @Anil_G, thanks for your reply. Which version I have to register in to get that functionality? Already tried ‘UiPath Automation Cloud Trial’ and still was not able to download the ‘UiPathStudio.msi’.


In the community msi once you open…you would see advanced settings where ypu can try selecting register uipath robot as windows service



Thanks for your reply @Anil_G

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.