Run UiRobot process from Windows 10 Task Scheduler

In case of using domain account as service account for robot it is essential to use this format including domain otherwise robot will fail with error “Executor start process failed”

Hello @Neeraj83,

After you have done a) & b). Just change from “Run whether user is logged on or not” to “Run only when user is logged on

Prerequisites for this to work are:

  1. Robot version 2018.3 is the last to support --monitor. Hence you must be on Robot version 2018.3 (Including all minor versions) or lower. Details here.
  2. The system account used to create the task must have logged in to the system once and its okay if it’s in locked state.If the user is Signed out it does not work.

Kudos :slight_smile: Hope this helps !

Regards,
Nithin Prabhu

Hi,
Tested with 2018.4.1 and it still works like before.
Cheers,
Josef

Hello bobpeers

Can you please eloberate it. I am trying to schedule my task using user logged in or not option. Is it possible. If not can you explain me what the other option is. I have seen your posts but I am in bit confused

Not sure if things have changed but I can only run schedules if the robot user is logged into the server. We leave them logged in all the time and just disconnect the RDP session when done.

Thanks for your prompt response. I am scheduling it in VM from my desktop. So, when I use “Run only when user is logged on” I tried to come out of VM to desktop by keeping the login session without disconnecting. But, when I came out of it, it stops executing SAP and remains at the same please. Could you suggest me on the same

It’s Clear It’s no possible with Latest Versions of UiPath. Consider close this topic and make a special note in Documentation so People can be aware of this limitations.
Thanks

Yes it looks like this feature does not work anymore with the FastTrack release 2019.4.2. You can still run processes from command line but not from task scheduler. I reverted back to 2018.4 because of this.

Hi,
I recently upgraded my test machine to 2019.4.3 CE
I tested running my unattended background test job with positive result. So far everything looks okay.
I am running it in VM under W10 Ent 2016 LTSB

Cheers

1 Like

Hi, I want to confirm schedule task still running in 2020.2.0 version?

Tested with last beta (20.3.0-beta0084) with positive result.

Cheers

Hi @J0ska,

If the system is locked. Will the robot unlock & run the process ?. This used to happen with --monitor command line argument to UiRobot.exe. This was discontinued from 2018.4 onwards.

Regards,
Nithin

Yes. Robot is running fully unattended in background.
In CE the UiPath.Service.Host needs to be installed manually and it must be installed to run in background.
The need of robot’s credentials in Credential Manager (UiPath:user=****) remains the same.
The --monitor command line option is indeed not needed/supported.

Cheers

Hi @J0ska,

Could you please post the steps how you got it to work ? It will help a lot of them. You can create a post just like this one.

Regards,
Nithin

Hi, thanks for the very helpful info on this and other posts!

I somehow can’t get my test robot working anymore using the Windows Scheduler. The robot should be running on MS Azure VDP.

The action I used:

Run program: C:\Users<username>\AppData\Local\UiPath\app-19.10.4\UiRobot.exe
Arguments: execute --process “processname”

Any idea what’s wrong? Am I overlooking a setting on the server side?
The Scheduler says the action has started and completed but without the expected result.

Enterprise or Community version?
Did you check EventViewer for any UiPath related errors?

Cheers

Community Edition and just checked the log which shows an error…: “System.Exception: UiPath user-mode Robot Service failed to start!”

I also just tried to run with the Robot (version 2020.2.0). And had a different response which is new to me: “A required privilege is not held by the client. (Exception from HRESULT: 0x80070522)”.

In general I feel it has to do with privileges.
Thanks

In order to run robot as background job you need to install “UiPath.Service.Host.exe” service, e.g. like below.

set USERNAME=donald
set VERSION=app-20.3.0-beta0084
C:
cd C:\ProgramData\%USERNAME%\UiPath\%VERSION%

UiPath.Service.Host.exe install
UiPath.Service.Host.exe start

Cheers

2 Likes

Morning J0ska, seems your suggestion did work contrary what I stated before. There was one other important step which I overlooked before and that was the fact there were two version installed on my VM. Next to the 2019.10.4 also a beta-version was installed. So I de-installed all related UiPath apps and did a clean install. Seems to be working now.
As a knock-on effect I had some issues with Excel and Google and fixed them while re-installing those apps as well. Thanks for the help!

1 Like

Anyone tried to set the user as “System” in the task scheduler?

First tab page in Property -> General

Change User or Group
Type “System” and check name