Run project from Uipath Assistant - The UiPath Executor.exe run make CPU overload

Hi Everyone.

I have a project, i run it directly on local machine and very fast and CPU fine, not overload… But when i published it into the orchestrator and run from Uipath Assistant then the uipath excecutor.exe run made CPU overload and make the Execution Log file very heavy and it run very long time.

I dont know what it is make this issue.

I have made another topic but still received exactly solution.

Thanks in advance!

Hi @Mr.H

Does the same happen if you try a very simple, empty project with just a few log messages?
(this could help isolate this behaviour to a specific part of your process)

1 Like

Hi Bro.

Thanks you!

I have remove all activities and keep only some simple log messages.

Publish it into the orchestrator and it ran fast and Execution Log very little.

The last source code, i have used For Each Row to loop 2 Datatables, on local machine it ran fast but when published into the orchestrator it ran very slow although i removed all activities inside of loop datatable.

Thank you. This indeed confirms that the issue relates to iterating over the data table. This might relate to the amount of the data in said data tables (are they big)?

What is your current Studio/Robot version?

1 Like

Hi Bro.

I have created a small project as attached picture.

I have two datatable, DT1 has 100 rows & DT2 has 140 rows.

When i use ForEachRow activity to loop 2 datatables:

1 - If i remove “Assign” activity out of loop and public into the orchestrator. The project run very fast and the Execution Log file very small.

2 - If i use “Assign” activity inside of loop and public into the orchestrator. The project ran very slow and the Execution Log file very strong as below picture. => ISSUE

But with that two case, if i ran project directly on the server, it ran very fast.

I dont understand about this issue. I have tried many ways but still could not fixed.


image
image

Hi @Mr.H ,

Are you using Global Exception Handler? Also, what is your log level settings?
Thanks!

1 Like

Hi Bro.

I have resolved this issue by change from verbose log into the information log on the orchestrator.

Thanks you!

2 Likes

Thank you for confirming the fix!