Run a process as administrator // Studio 20.10.2

Hello,

I have installed the latest version of Studio (20.10.2) and I have an issue when I try to run a process with Administrator rights.

The Studio is licensed, installed on VM and I don’t have/use Orchestrator.

Steps followed on the previous versions on Studio:
-open the Studio or the Robot with “Run as adminstrator” and press Run from the tool

In 20.10.2 version when I open a flow in studio (already openned with Admin rights) I see the below error.

image

image

I searched that error on the forum but those solutions didn’t resolve this issue.
Can you please help me with some ideas?

Thank you in advance,
Vlad

Are you using the community version?

No, the enterprise.

Hi @VladTof,
What does the robot assistant window show in – > Orchestrator settings? It should probably also show that your are currently unlicensed as well.

The error to me looks like a license issue, which you probably can check in the “Robots” section of Orchestrator. If your admin user is a different Active Directory user (with a separate username and password) then this error makes sense because modern folders provision robots on users (Named user license) and not robot machines (which Classic folders do).

If it is an enterprise version you are running, then I am sure that UiPath.Service does not require admin rights nor does UiPath Studio, its a system (VM, PC, VDI, Server) wide service / installation and not a user specific service / installation. So that should not be an issue here.

The Studio is licensed and it is installed on VM and I don’t have/use Orchestrator.
I don’t understand your last paragraph. The Studio does not require admin rights but I want to run the process with admin rights because I have some selectors which the robot cannot see without admin rights.

@VladTof
Delete the machine and robot from orchestrator. And follow these steps.
1- Check your machine name and add the same machine in the orchestrator
2-The machine key that is generated by orchestrator, add it in the Orchestrator settings with path. Kindly check below screenshot.


3- Create a robot “unattended” and fill all the fields. To fill domain name, enter whoami Command in cmd.
4- Assign environment to robot.
Now check is it still giving the same error?

Happy Automation :slight_smile:

Regards
Nashrah Khan

This is normal behavior, why you are trying to open as admin? As you do that, you are not using the actual logged in user…

The robot is not able to see some selectors if is not running with admin rights (also when I select that element using UI Explorer a pop-up advice me about that).

It is not a normal behavior while the previous version of Studio worked very well when I followed the same steps.

The part of the selector cant work without admin is because the other application is running with admin and both processes (robot and application) must run on the same user to work. You should take a look at which user the Studio uses when you run as admin, but the best would be to put that user in Administrator group of the pc.