RPA run in Remote Desktop

Hello, I wanted to see if anyone has had this scenario

I have a robot that I want to put on a remote desktop, I was testing it with an orchestrator on the local machine and it worked perfectly, but when I move it to the remote desktop, and I try to execute it, it displays the following error
image

the error only happens to me when I do not have open the remote desktop session, but I have another small robot that writes a log in a txt which if it works

Hi @Francisco_Benavides,

Great…!

Kindly correct me if i understood your question correctly or not,
So the workflow that you designed works well in your local machine and it fails when executed in other remote server.

For this case, this error( that you mentioned above ) will usually occurs
when there is mismatch in software versions been used and even unavailability of softwares.

Kindly check with them. Lets sort this out…

Cheers…!

2 Likes

Sorry for my English that is a bad enough but I will try to explain my problem

The robot migrates it to a remote desktop, I run it from orchestator with the remote desktop session open and it works, but when closing the remote desktop window I run the process from orchestator again and it gives me the error that I mentioned before.

Case 2
I have a simple robot that writes a txt the date in which it was executed, I execute it without opening the session and the same one if it works well.

My question here would be if the robot needs to interact by clicking with the browser and I do not have the session open, is it not possible to execute it?

1 Like

Hi @Francisco_Benavides,

No Worries buddy…! You are good in communication. Bravo…!

I think this error occurs because the bot is not able to access the elements in background.

kindly use enable the simulate click or simulate typeinto property check box,
in typeinto and click activities that you have used in your system. This helps to run the process even in background.

Lets try this buddy.

Cheers…!!