RPA Advanced DEV training assignment 1 issue

Hello everyone,

My issue is trying to open the UiDemo.exe by specifying path from config file which I did in Assets sheet.
and it throws error “Object reference not set to an instance of an object.”

Tutorial says: “The Config dictionary is already used as input argument in the InitAllApplications.xaml workflow, so let’s change the filename path to in_Config(“UiDemoPath”).ToString.”

Where is it even getting in_Config argument from? as in no point was it specified.
There was in_ConfigFile and out_Config.

2 Likes

There is a variable named config in the main workflow which is a dictionary.

In the init state, you are invoking InitAllSettings and InitAllApplications

InitAllSettings - has three arguments in_ConfigFile, in_ConfigSheets and out_Config
In the invoke workflow, click on import arguments you will see the above arguments and it got assigned with the following values.

in_ConfigFile - Data\Config.xlsx
in_ConfigSheets - {"Settings", "Constants"}
out_Config - Config

Here once the InitAllSettings workflow executed, out_Config will be filled with the configuration values from the excel sheet and gets assigned to Config in the main workflow.

InitAllApplications - has only one argument in_Config
In the invoke workflow, click on import arguments you will see the above argument and please assign the following value.

in_Config - Config

When you are opening the application, give the path as in_Config(“UiDemoPath”).ToString
It will work.

4 Likes

Hello Karthik

Tutorial does not specify to pass anything to invoke workflow, It specifies testing individually the sequence InitAllApplications.xaml , I did pass the value Config to argument.

Still get same error.
image

Hi @Aryx

In the normal application also (not only for testing), you have to assign the config to in_config for the InitAllApplications workflow.

After that, inside the workflow where you are opening the application, give the path as I said earlier.

Regards,
Karthik

Hello @KarthikByggari

Thanks for prompt responses.
The Path was already specified: in_Config(“UiDemoPath”).ToString

But how do I assign Config to in_Config? Config is a variable in Main workflow and is out of scope of InitAllApplications.xaml

Regards.
Arthur

Where you are invoking the InitAllApplications workflow?
It has to invoke after InitAllSettings workflow in the Init State.
So Config will be in scope.

If you mean where the Invoke Workflow happens then as I said earlier - I already did that ,

That is right. And I don’t see any error here.

Well the error still persists.
I think it’s not getting anything into in_Config at all.
I tried printing it using message box and .ToString.
And message box threw same error.
image

Can you upload your workflow InitAllApplications.xaml

InitAllApplications.xaml (7.3 KB)

Sure.

I have the same issue. I’ve been searching for others with the same issue without luck. Also having trouble with in_Config"(QueueName").ToString in GetTransactionData workflow.

Same Error message: “Object reference not set to an instance of an object”.

@Teewin

the QueueName has to match in the Config.xslx -> Settings Sheet
Name / Value
QueueName / [What you named the queue in Orchestrator]


@Aryx
Here’s a screenshot of my config.xlsx and Orchestrator queues.

Is this correct? I am getting error with this.

@Teewin
It does look correct , probably issue is with passing arguments then , similar to mine.

@KarthikByggari, @Teewin, @Aryx

I was facing this issue for past 2 days and finally hit on this thread - going by @KarthikByggari notes, I was able to overcome this … Thanks a lot @KarthikByggari

I know its been some time - but has this problem been resolved @Aryx ?

1 Like

I’m still struggling with this issue but can’t seem to resolve it.