Robotic Enterprise Framework Deep Dive - Config file

Hi,

I’m working on the Robotic Enterprise Framework Deep Dive assignment, and I believe it is pretty difficult to figure out the actual process when the explanation is super outdated. I’m using the modern template without the “GetAppCredentials.xaml” and now I’m having issues with the “InitAllApplications.xaml”.

The walkthrough says to use an Open Application activity = Use Application/Browser and to change the FileName from the actual path to a more robust way to work which are Assets. Not to create an asset on Orchestrator but to use the Config file and write the Asset name
in the Assets sheet.

Quote: The Config dictionary is already used as input argument in the InitAllApplications.xaml workflow, so let’s change the filename path to in_Config(“UiDemoPath”).ToString.

This is what I get from UiPath:

I don’t get why the error. Shouldn’t the activity get the asset from the config file?
I know there’s no path in the Config file, but the error confuses me. Can anybody tell me how to configure this file?

Thank you,
Marco Mendoza

Hi @mardoza,

In stead of the Assets tab, use the settings tab:

Just to be sure, can u show me the “Import Arguments” from your Login-workflow? That might be causing the problem aswell.

Kind regards,
Robert

Hi,

I made the change but I’m still getting the same error.

image

These are the arguments:

And here’s the Login process.

UiDemo_Login.xaml (17.3 KB)

Hi @mardoza,

I have seen your workflow, u dont need arguments for this workflow, just convert them to variables, but the workflow is disabled, so thats not where the problem came from.

Can you also show the arguments for the InitAllApplications.xaml?

Thanks!
Robert

Yeah! I actually deleted those arguments. On the Arguments tab, I only have the in_Config.

Try this argument in InitAllApplications.xaml:

I tried and it says - “…‘Config’ is not declared. It may be inaccessible due to its protection level.”

Config should be there in the variables, can you check:

I’m sure you’re in a different file. I’m working on InitAllApplications.xaml and there are no variables.

Inside the InitAllApplications.xaml create the Argument in_UiDemoPath as type - string direction - in.

Then follow the next screenshots:
2022-10-21 00_05_08-RoboticEnterpriseFramework - UiPath Studio Community
Go to the first screen of the REF and doubleclick on Initialization


Scroll down to InitAllApplications and click on “Import Arguments”


In the value fill in: Config(“UiDemoPath”).ToString and click OK

Let me know if u have any questions!

Robert

I did what you said. Look:

I tried retrieving the value.

It runs, but it’s not showing the message.

Any idea?
Thank you so much for taking the time.

@Robert_Lansbergen It is working now. All I had to do was to Invoke the Login Workflow and it ran fine.

Thanks again for your help!!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.