Robot unresponsive error on orchetsrtor

Getting this error while connecting to Robot on PROD server : No connection could be made because the target machine actively refused it.

No Connection Could Be Made Connecting UiPath Assistant To The Orchestrator Because The Target Machine Actively Refused It

Below is a troubleshooting guide on how to resolve the error "iSettingsOperations.ConnectToServer threw System.Net.WebException: “Unable to connect to the remote server” which is thrown while connecting UiPath Assistant to the Orchestrator.

  1. Check the application event logs. If the error “No connection could be made because the target machine actively refused it orch_server_ipaddress/hostname:443” is observed in the Application event logs, then move on to the next step.

  2. Make sure that it is possible to browse the Orchestrator site from the robot machine without any errors. If it cannot be reached, make sure that all the services the Robot connects to have been whitelisted in the firewall, see outgoing connections in the document Services The Robots Connects To .

  3. Check in Services in the Robot machine whether the Robot is installed in User Mode or in Service Mode. When in Service Mode, you will see the Local System service named “UiPath Robot”, which will not be present if installed in User Mode. Once determined it is installed in Service Mode and determined that the connection fails, then follow the below steps:

  4. Most likely, the Robot machine is sitting behind a proxy. This can be checked from Internet Explorer LAN settings. If proxy details are configured, then provide those details in the relevant config file(s) as per the Redirecting Robots Through A Proxy Server documentation

  • Make sure the documentation page matches the version of the Robot that is installed.
  1. If the above configurations were already done but the issue persist, try removing the bypass related key-value pairs from the config file, restart the Robot service and try connecting again.
  • This happens because Orchestrator might be configured as a local address and will not be routed through the proxy server if “bypass=true” for local addresses is enabled.