Robot unlicensed status

I installed Orchestrator with evaluation license codes, in the same machine I installed studio and robot, when I connect robot with the orchestrator the robot is available but with an unlicensed status, thank you for your help

1 Like

Hello @wahid

You said that your robot is associated with the development Studio as both the robot and the studio is installed in the same machine. I think the robot type you selected here as unattended is causing the problem. Can you change it to Attended instead of Unattended and see whether its working…

Kindly mention the exact machine name as in this picture, while creating machine in orchestrator

Because I can see like it’s in small case here

And also ensure that the username and domain mentioned while creating ROBOT for this machine is correct and to get the right domain/username from your machine, go to Cmd window and type the command as whoami which will give us the domain/username
Mention the same while creating a robot for that machine

And keeping unattended type of robot is fine if we want to run that Robot without human intervention

Kindly try this and let know for any queries or clarification
Cheers @wahid

1 Like

Thank you for your quick feedback.
I tried everything, the name of the machine, the domain / name see the screenshots below:

1 Like

Thank you for your return back
ion the same server (Windows Server 2016) I have the orchestrator, robot and studio, I tried to change everything but it does not work

Did you purchase license for a unattended robot?

Just try with all robot types there… Unattended, attended and also development type…

No, but I have a license code for these types of robots

Hmmm…It seems like a Floating Robot
Kindly create a Standard robot and try once
Because only when floating robot is created this can happen…,

Cheers @wahid

1 Like

Thank you for your return,
but it is a standard robot

Hi @wahid,

Have you tried by changing its license type to Attended?


Yes i did

This is just a hunch… Not sure whether it works, but just give a try…

Your machine name is in all caps in the Orchestrator settings in the robot tray. However, in the machines page in orchestrator, it is in all simple. Can you try creating your machine again with the name all caps exactly as shown in the Robot tray… Just give a try and see whether it works…

Thank you for your feedback.
I have already tried any type of robot, and well try the names of machines and robots between upper and lower case.

Hello community,
I still have no solution to my problem, help plz

I’m just testing out with Studio/Robot 2019.10.1 and Orchestrator 2019.10.14.

If I connect Robot to Orchestrator; having a Machine record but no Robot Record in Orchestrator, The Robot reports as Unlicensed.

Adding a standard robot with Type of Unattended and the matching credentials, after waiting for the heartbeat, Orchestrator shows Status as available but Robot shows Unlicensed still. After adding the Robot to an Environment associated with a process, I was able to start a job from Orchestrator and complete successfully on the Robot (Robot Tray status still showing Unlicensed).

Left clicking to bring up the Robot dashboard or Disconnecting and Reconnecting the Robot from the Robot’s Orchestrator Settings window, refreshed the Status to show Connected, licensed.

Also, please hover over “Sans license” status and the tooltip will show the reason why it says it’s unlicensed. Hopefully that will give us a clue.