Robot Takes Longer Time To Install Package In Every Execution

How to reduce the longer package installation time (more than 2 minutes) that Robot takes during each run?

Root Cause:

The behavior is observed is when the Robot doesn't have access to the online feeds like myget.org, nuget.org and other feeds listed under 'Downloading packages' section mentioned in the Services The Robot Connects To . The Robot tries to reach these feeds (and even UiPath Marketplace feed, i.e gallery.uipath.com if configured) if the project has a dependency on some activities that are not available in the Local or Orchestrator feed (if Robot is connected to the Orchestrator)

Resolution:

There are two ways to resolve the issue
  1. Whitelisting the online feeds (in the Robot machine) listed in the Services The Robot Connects To under 'Downloading packages' section
  2. Stopping the Robot to reach the Online feeds using the below mentioned configuration in detail.

Disabling Online feeds: This option is available starting from 2019.4.2 or higher versions.



While installing the UiPath Robot:

UiPath Studio .msi Installer needs to be executed with the following parameters [ Command Line Parameters ]
ADDLOCAL=DesktopFeature,Robot,RegisterService,StartupLauncher NUGET_OPTIONS=DisableOnlineFeeds

Note: The feeds URL are not removed from configuration files but they are not considered.



After the UiPath Robot was installed:

Add the following lines in UiPath.config located in the Studio\Robot installation directory,
  
    
  
Note: After making this change, restart the UiPath Robot service by following the below steps:
  • Navigate to Windows start menu and type Services.msc and press Enter.
  • Search for UiPath Robot and select it.
  • Right-click and choose Restart option.

Following image shows before and after changes in UiPath.config file
image.png

Other Steps:

Recommended for an older version (lesser than 19.4.2) of UiPath Robot and also, if in case the above does not help (in case of machine wide nuget feed configuration)
  1. Navigate to following path C:\Windows\SysWOW64\config\systemprofile\AppData\Roaming\NuGet\NuGet.Config and do the below changes
  • Comment out

  • Add

  1. Navigate to following path: %userprofile%\AppData\Roaming\NuGet\NuGet.Config and do the below changes
  • Comment out

  • Add

  1. Navigate to following path \NuGet.Config and comment the below lines

  1. Restart the UiPath Robot service after making above changes
  2. Start the process and validate the behavior.
2 Likes