Robot stuck in running mode without any apparent error

After the update of Studio from 2019.7.0 ==> 2019.8.0 , the robot Keeps getting stuck while executing the project I’m currently working on .
The Robot gets stuck at random activities everytime .
I tried uninstalling and reinstalling Studio and Robot , creating another project and using the same files from the previous project, but with no result .

The project runs normally on another machine , using the same version of Studio (2019.8.0) , but not on mine

Can anyone help with this issue !!!

Thanks everyone

Hi @Nawfal_Hamdi,
Please notice that since 19.8 the default start button behavior is to run workflow in debugging process. If you want to run as it was before you need to choose small arrow below and click the right option.

Thank you @Pablito , but that’s not the problem . I already used the start File , and Start File Without debugging , and it keeps the same behaviour . The only diffrence is that when I start without debugging , I don’t know where the robot is stuck , and it keeps like that until I stop the process.

Seems that it’s similar issue to this topic:

Can you check the file uploaded by @loginerror in this post?

1 Like

Hello @Pablito , thanks for your help.
I downloaded and executed the Try_catch workflow , and it works just fine .
But my process ( after working perfectly fine yesterday) , keeps getting stuck again today .

The robot is stuck like this for 15min without any error or breakpoint.
When I run the process without debugging , it gets stuck before opening the browser ( the 2nd workflow in my Main.xmal , after some configurations and read/write in excel files).

This problem occures randomly in my workflows , it works sometimes , and then gets stuck after some executions .
I would appreciate any indications or help in this matter .


I’m not sure but maybe during latest update your robot wasn’t fully updated against the Studio. Please check this post from @loginerror and mine as well here:

Thanks for the response . I checked the path of UiPath.Executor , and it pointed to the app-19.8.0 which I suppose is the correct path, but the problem still persist .

I would appreciate any further help :smiley:

I’m facing the same issue. The robot does not do anything, it’s just stuck. Stopping the stuck process, I can’t restart it. Basically all control buttons (start, new, save, etc.) are faded and can’t be clicked. Also, I can’t close Studio. I have to use task manager to exit. Starting over, same thing happens again. Any further ideas?
Can I maybe still get 2019.7 somewhere? I need a fairly recent version to get Edge automation running (does not work with most recent Enterprise edition 2019.4)

Have you tried to reinstall it?

Please check my previous post:

I have found what caused the issue , It’s Microsoft Office 2016 Professionnel Plus … I have installed another version of Microsoft Office , and now it’s working perfectly .

1 Like

also be aware that my processes facing the same conditions, initially I thought it is the office issue like you.

I uninstalled and reinstall newer version and it is working for awhile for a day . Later hanging start again.

later realize that Windows update (ver 1903) caused the hanging all programs using until it released the patches at the end of August to fix that issue.

so please make sure did you update ur window recently?

I did update windows recenlty , it’s version 1903. And I installed MS office 2013 , it’s been 3 days now , and no problem has appeared so far

Same problem. I do not have Office 2016 nor Windows 1903 installed. Bot stops, but doesn’t let me know it stopped. It just sits there. Reinstalled UIPath, issue persists.

Now I am looking for a way to downgrade back to the previous version. I would also like to know how to turn off automatic updates because they clearly are not testing the updates before they roll them out. I would prefer to opt out of being a beta tester. Between this and the months they left us high and dry after the Chrome 71 update, I am looking for other RPA software altogether. I don’t feel UIPath is ready for Primetime yet.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.