Robot not starting with command line


I am trying to run bot without orchestrator, I’m using below command to run but bot is not starting:

C: \Program Files\UiPath\ Studio\UiRobot.exe -file
“D: ****.1.0.1-alpha.15.nupkg”

If you need to run the robot without Orchestrator, make sure the robot is licensed locally before running it.

Try like this:

"C:\Program Files\UiPath\Studio\UiRobot.exe" execute --file "D:\****.1.0.1-alpha.15.nupkg"

Reference: Arguments Description

How can we license the Robot locally?

First, try to run the above command, and check if you have an error.

Tried but the issue still persists

Show some screenshots to see what kind of errors you have. Check the Event Viewer → Windows Logs → Application

What is the Studio/Robot version?

It is an unattended robot or an attended one?

Where did you install the Robot/Studio?

Studio version is 2022.4
Robot version in 2021.10
It is unattended robot

Opening below screen and closing automatically

For long as I know, to run unattended jobs with unattended robots, you need to be connected to Orchestrator.

Try to install the robot in attended mode, and then try again the command line.

For activating the robot/Studio without Orchestrator, you may take a look here Activate Studio

I have connected robot to orchestrator using machine key, but it is showing as connected, but cannot acquired license. I have allocated license to machine

Check if you have these settings in your tenant settings.

Hello @Rohit_More

Can you try with the main.xaml instead of the .nupkg and check whether it’s working or not.

UiRobot.exe execute --file "C:\UiPath\Automation\Main.xaml


UiRobot.exe execute --file "C:\UiPath\Automation\Project.json" :warning:
UiRobot.exe execute --file "C:\UiPath\Automation\Main.xaml" :warning:

Is not supported for Windows or Portable projects.

The command is working fine, the issue now is robot is not connecting.
Installed Robot is unattended and is up to date.

For attended robot cannot change option.

Disable the User license management and you will be able to set the Attended robot Authentification to Hybrid.

How can we do that?

I do not see this option.
Note: I’m using community edition

Show how you configured the Assistant machine key or Client ID connection.

Show how you configured the Unattended robot in Orchestrator UI.

Machine Type: Template
Robot Version: 2022.4.4

Can you make the Chrome default browser and then Sign in in Assistant?