Robot Not Performing in Unattended Mode giving Timeout Error

How to troubleshoot when the Robot does not perform in Unattended mode and Robot is unable to click on button in Unattended mode along with error of timeout?

Check for the prerequisites of the Robot installation (also the Local Computer Policy)

For Unattended Robot, properly logoff/sign-out from the Robot machine and not disconnect.

undefined

Also the resolution settings in dev environment and that should be same in the Robot machine as well in unattended mode. Visit the Forum Link explaining the Resolution Settings of Unattended and follow the steps.


Ensure proper resolution setting has been defined i.e. height, width & depth.

Approach #1 : Latest Version Of Orchestrator


The below snapshot shows the configuration done in one of the machines for the Robot to execute in unattended mode with a specific resolution. The resolution is taken from the dev environment where workflow was developed and applied on the Robot machine in UAT/ PROD environment.

Enable Login to Console and set it to No, (which means false)- similar to below.

Enable depth & provide the value as 32,

Orchestrator resolution

Also, the resolution defined should match the resolution of the development machine where the process was developed.

For Example: In development machine, the display is 1920 * 1080, thus value is provided accordingly.

Before applying ensure cross-check the resolution settings.

display settings

Approach #2: Changing the UiPath.Settings file for the older version of orchestrator (resolution configuration is not available)

uipath settings file

How To - Setting up Approach # 3:

Development machine from the Studio:

1. In the development server:

  • Use the "Take Screenshot" activity. Using this activity, do not select anything on the screen, select the entire desktop.
  • Use "Save Image" activity to save the image at the desired location.

2. Check the details tab in the properties of the image saved. Note the depth, height, and width.

Once all the details are present, Login to Orchestrator and change the Runtime settings(Resolution Width, Height and Depth) for the Robot which is running as mentioned in below screenshot -

  1. Robot machine:
  2. Login to the Robot machine.
  3. Open UiPath folder under program data. Add in UiPath.settings(path : %programdata%\UiPath\UiPath.settings) file the height depth and width noted in the appropriate parameters. Logintoconsole: false (small f)
  4. Restart uipath Robot services (Run -> services.msc -> Uipath Robot -> Restart)
  5. Reboot the machine.
  6. Logoff from the system.

Post following the above steps, check if able to run the job from Orchestrator in Unattended mode and note the outcome.

​Note: Enure to Logoff/Sign off from the Robot machine, rather than disconnecting.

Approach #4 : Verify that an Enterprise version of the Studio and Robot is being used

Check the "Help" section of Studio and verify that the installed version is "Enterprise Edition" not "Enterprise License"

If a community version has been installed, uninstall it and install the desired enterprise Studio and Robot.