Robot Not Downloading the latest package from Orchestrator

I deployed a new package to the Orchestrator from studio and updated the orchestrator process. I can see the new package available for down load in the robot machine but cannot download it. I looked at the event viewer and found this “System.Net.WebException: The remote server returned an error: (404) Not Found”. I tried reinstalling the bot , re-provisioned the robot in the orchestrator but nothing worked.

1 Like


I am able to download latest package. Could you please try again.

@lakshman , I am able to update the orchestrator but my problem is in updating the unattented bot.


Are you using community edition or Enterprise edition ?

If you are using Enterprise edition then raise ticket in UIpath support and they will help you.

Hi @paul4thee,

Can you share the screenshot of your robot machine.

Not exactly helpful, we’ve raised it with UiPath support and they weren’t particularly helpful either.

Things we have tried:
-Increasing the package size limit in IIS to 1GB - same error
-Installing Studio just to download the Activities required on the Prod or Unattended Non-Prod machines - works, but not exactly a fix

It turned out to be an issue with the security certificate. I uploaded the correct security certificate and the issue is resolved

Hi Paul,

What steps you took to update the security certificate? I have the same issue wherein i published the code to orchestrator but my unattended bot is not showing latest package downloaded.