Robot not available in Ui Robot

Hi there,

I changed the Domain\user name field according to whoami in Command Prompt and I’m always getting the information “Robot not available”.
I checked and double checked everything, and everything is fine.

1

Hi @jcab

Can i see a screenshot of the robots page in your orchestrator?

@jcab

You have not specified the machine for the robot. Go to edit and specify the machine that you created under the machines page for the robot. Then it should get connected without any problem.

Also make sure the machine name is the same name as your computer name

If this works please mark the answer as the solution so it could help others as well

Hi @jcab ,

You need to replicate same changes in Orchestrator

  1. Login into Orchestrator (https://platform.uipath.com/)
  2. Select Robots optin
  3. Mouse hover over the required Robot in the robot list and Click on Pen(Edit) icon.
  4. Description screen will pop up
  5. Update the new Domain\User field and/other nay other change you made on your local machine. Please refer the below screenshot for more detail:

I misses one point. You need to specify the environment as well. Every environment has one or more robot. So create an environment and link the robot to it. And specify the machine name. Then you should be good

If I go to “Edit” under “Machines”, then I get the following screen, where I’m unable to select anything related to that.

This is the order to follow…

  1. Create a machine
  2. Create a robot
  3. Create an environment and link the.robot to the environment

@Lahiru.Fernando

That’s exactly what I already did, before opening this topic…

I’ve uninstalled and installed UiPath right now, but the problem persists.

Uninstalling and installing doesnt help. First go to environments in orchestrator and click on edit, then in the edit page, can you try adding the robot to that?

@Lahiru.Fernando

Yes, I can.

Now check the robots page to see whether it has got updated… and also see whats missing…

@Lahiru.Fernando

Robot page and the edit page.
Everything is exactly in the same status as what I described in my 1st post.

In the robots creation page there is a place to add the machine as well

Try creating the robot again… it should work… delete the robot and create a standard robot

No, there isn’t any place in the robot creation page to indicate the machine.

I already deleted robots and created more than 5.

The issue persists :slight_smile:

I think I’ll give up and try tomorrow in the office again.

You have to create a standard robot. Not a floating one. That option is only available for standard robots. The one you have created is a floating one. Under new robot -> click on standard robot

Yes, that is true: the option to select a machine in the robot page is only availabe for standard machines.
And I also have tried that before opening this topic…

Can i see a standard robot creation page you get?