Robot losing connectivity with Orchestrator after upgrading from 2020.10 to 2022.4

We are a cloud customer. After upgrading Studio/Robot/UiPath Assistant from 2020.10 to 2022.4 we are frequently (multiple times each day) losing connectivity between our Robot and Cloud Orchestrator. To restore connectivity we have to restart services on server or restart server. Anyone else having this issue? If so, -any recommendations/resolutions? Thank you.
-Steve

Hey @Bramson_Steven

You mean to say you are restarting the robot service in the server ?

Thanks
#nK

Hello @Bramson_Steven

Did you checked the logs?If yes, got any information regarding the abortion of robot service in server?

Yes, I am actually restarting these three services and this is reestablishing connectivity.

Please note, the services always show status = ‘Running’, -however this appears misleading as when I restart the services (specifically ‘UiRobotSvc’), connectivity is typically reestablished.

Steven Bramson

(310) 430-1158

Sr Business Systems Specialist

SBramson@StanfordChildrens.org

Stanford Childrens Health Lucile Packard Childrens Hospital US News and World Report Badge Logo

1 Like

This looks perfect @Bramson_Steven

Can we know how did you make the robot upgrade ?

Hi Nithin, -can you elaborate further on your robot question?

Steven Bramson

(310) 430-1158

Sr Business Systems Specialist

SBramson@StanfordChildrens.org

Stanford Childrens Health Lucile Packard Childrens Hospital US News and World Report Badge Logo

1 Like

Hey @Bramson_Steven

Want to just know if your robot and orchestrator versions are compatible enough. Also please mention the version ?

And how long are you facing this issue? Was this working fine before ?

Thanks
#nK

We are a cloud customer (automation cloud) so the orchestrator version is always current.

As a cloud customer we still have a few components on premises, namely a VM for our robot. The upgrade for Robot/Studio/UiPath assistant was from 2020.10 to 2022.4.

The connectivity issues begin immediately after upgrading to 2022.4.

Steven Bramson

(310) 430-1158

Sr Business Systems Specialist

SBramson@StanfordChildrens.org

Stanford Childrens Health Lucile Packard Childrens Hospital US News and World Report Badge Logo

1 Like

Hey @Bramson_Steven

Cool, could you please confirm the mode of robot please ?

Did you install it in service mode or user mode ?

Thanks
#nK

Hi @Bramson_Steven

If you haven’t already, I would strongly recommend contacting our technical support via this form:

(given that it is an issue with the production environment in an Enterprise scenario)