Robot is not available to run jobs!

Hi. I had a robot of type Studio which was being used since a year to run a job. But suddenly since yesterday, I don’t see the list of robots in “run a job” section after selecting the process. Since the robot was being used since a year, everything was configured correctly. I had the robot and the process in the same environment, the UiRobot’s status was always “Connected, Licensed”.

I searched on the forum and found several ways to resolve it. I tried all of them. I recreated the machine, robot, and the processes. Everything is well configured and still the robot does not show in the list to run a job. I don’t know the reason behind it. Everything was going good.

Finally I found out that I can no more execute a job with robot having type Studio. For that, I need to create Unattended type robot. So I removed all the robots and environments and tried to create a robot of type Unattended but I always get error:
“No available licenses: the number of new machine slots would exceed the total license count. (#1916)”.

The image showing list of available robots is attached for reference. Please suggest a solution to it.

Thanks in advance.

@sandesh-f3 - New cloud release having a changes related to robot types.

please change the robot type as ‘Unattended’ and try again. Robot will appear in start job window.

Go to Service instances and assign robot types to visible in robot allocations in licensing page.


You need to allocate the license from the Cloud Portal ( to your Orchestrator Service instance.


Thank you so much to both of you for quick replies. I am now able to create the robot and run the jobs. Thank you @codemonkee for references. That helped me fix it in no time.
Thank you again.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.