Robot Icon not present in systems tray

Thank you for your answer!

So, to be clear, what do I write in cmd? “Start UiRobot.exe /tray” ?

It needs to include full path to UiRobot.exe or you need to navigate to it’s folder first. Start is not required.

I see, thanks! Any clue on how to find UiRobot.exe? I am only able to find “C:\ProgramFiles (x86)\UiPath Studio\ UiPath”

1 Like

It should be in that folder…

If you can’t find it there, either it has been moved (I’m checking on 2016.2.6232) or you have a different problem and this is just a symptom of it.
Try searching from folder explorer in the installation folder.

Opening UiStudio should start the tray as well, so you could try that as a workaround if you need to get it working ASAP.

Ah, I found it, my bad. But when I run the command, I get the error “The term x86 is not recognized as the name of a cmdlet”. I tried all of the following versions:

C:\ProgramFiles (x86)\UiPath Studio\UiRobot.exe /tray
C:\ProgramFiles (x86)\UiPath Studio\UiRobot.exe --tray
“C:\ProgramFiles (x86)\UiPath Studio\UiRobot.exe” /tray
“C:\ProgramFiles (x86)\UiPath Studio\UiRobot.exe” --tray
“C:\ProgramFiles (x86)\UiPath Studio\UiRobot.exe /tray”
“C:\ProgramFiles (x86)\UiPath Studio\UiRobot.exe --tray”

The two last ones do not return an error, but the icon still does not appear.

When I click “customize” in the systems tray, the UiPath Robot does appear in the list. When I set the behaviour to “Show icon and notifications”, I get the info message “This notification icon is not currently active”.

1 Like

Alright, so this one did the trick:

start “C:\ProgramFiles (x86)\UiPath Studio\UiRobot.exe” --tray.

Thank you for your help!


In Windows 10 I had start the tray function manually by double clicking the app(UiRobot) from below path


I am having the same issue. I do not see the UiPath folder on my C Drive in either Program Files folders to accomplish what I have read here. I am using the Community Edition of studio and have setup a tenant, but I still cannot get a robot icon in the system tray. I am in the process of teaching myself UiPath through the training modules and completed studio, Trying to now complete the Orchestrator, but I am stuck at this point. I am using Windows 7 as my OS.

Try pasting the following link into the address bar of your file explorer:

After opening that folder, go ahead and open the most recent subfolder named “app-*”, e.g. “app-17.1.6522”. Within this folder you should be able to locate the “UiRobot.exe” file. Double click it. Check your systems tray and see if the icon appeared.

If that did not do the trick, try the following: hold the “Shift” button down while right clicking on the UiRobot.exe file, and click “Copy as path”. Then, write the following command into a command prompt:

start [PATH] –tray
where [PATH] is replaced with the complete path to the UiRobot.exe file that you copied above, surrounded by quotes “”.


It worked! The first option. I will now start over with my orchestrator training. Thank you VERY MUCH:slightly_smiling_face:

1 Like

This presents a usability problem for end users. The system tray icon used to automatically appear because of how the installer configured it, and now it doesn’t. Yes there’s a workaround, but how do we get this acknowledged as a defect?


Thank You so much . It helped me resolve my problem

1 Like

thank you so much!

1 Like

The lnk or link file will appear on windows , when the environment infected by virus . This is common for all apps and files

Hi TDagsvik,
by the above comment i was able to find the UI Robot, but neither double clicking is working nor the cmd thing giving error as system could not find the file

Thanks so much, it resoved the issue.

im using UI path version 2018…no such subfolder with name starting with app exists…
there is a cache file, configuration file, ui studio settings etc but not app* file.

ok its in my C drive program files 86… i have got ui path icon in my system tray
thank you :smile:

Just to close this one.

Here is a topic where you can find details regarding Robot paths and not only: