Robot fails when ran from orchestrator, Static Selector, Citrix(Centricity)

selector
orchestrator
citrix

#1

Hello,

I’m currently working on a robot that deals with a Centricity login box. The robot works without any issues when ran from UiPath. But, when I run the process/robot from orchestrator the robot fails at the Centricity login. The process can not find a specific selector. If selectors are not a good approach. How should I go about this?


#2

Share your selector if possible.

Selectors are good approach (if static), dynamic selectors need to be fine tuned.


#3

“<” wnd app=‘wfica32.exe’ cls=‘Transparent Windows Client’ title=‘Centricity Practice Solution - \Remote’ “/>”

I am positive it is not a dynamic selector.

edit: showing selector.


#4

Also, I did try to use the UiExplorer to better identify the selector.


#5

Try kicking it off using Launch Workflow Interactive activity with proper resolution and color depth used while designing it. Corrects most issues that occur while migrating from Studio-run process to Orchestrator. Usually, it’s caused by image-based actions.

Regards.


#6

I did attempt this. No luck. I don’t believe this an image-based issue.


#7

And, you published it with the workflow containing the new Launch Interactive activity so it runs the correct file? If you are not sure, verify the project.json file inside the project folder that the Main is the correct file.

Are you running the process on another user account or machine than you did when you ran it successfully? If that is the case, then my suggestion would be to test it on that environment first before publishing.

If that is not helpful, if you could provide screenshots and the exact error message, then maybe someone here can get a better idea of the problem.

Thanks.


#8

uh you know what… I guess it is working. Sort of. But, I’m getting this error…

Normally the process clicks on CPS and then the Centricity login approaches.

I received the same Selector error from both Invoke and Launch workflow. But,

With Invoke when I log into the account running the process after it failed, there is nothing on the screen.

With Launch workflow I logged back in and saw this error sitting on the screen.

  • Do you think that the same error shown in the picture is occurring when I use Invoke Workflow as well?
  • If a process fails when called with Invoke workflow, does the process automatically log out?

I’m guess this isn’t UiPath related(?)


#9

Hmm yes. Both errors seem to occur no matter which invocation I use.


#10

Just an update in case this happens with anyone else. Apparently this is an issue with old UiPath software. I will send another update on what happens after my team and I update the software.


#11

Updated to the latest UiPath and Orchestrator version. This problem is still persisting. Just bumping to see if anyone else has an idea on how to handle this.


#12

Not sure if its correct , but I see your Selector has “Remote” in the Title. If it is a Citrix based app, then selectors will not work.

<” wnd app=‘wfica32.exe’ cls=‘Transparent Windows Client’ title=‘Centricity Practice Solution - \Remote’ “/>

if you are having issues click the CPS icon, you can try modifying resolution settings in Uipath Settings file %programdata%\UiPath (until 2017.1) or RunTime Settings in orchestrator (from 2018.1)


#13

Hmm, well this selector or Centricity login box never pops up because of the two errors that popup in the above photo.

It does in fact click on the CPS icon.


#14

I think you need to check with your support Desk regarding those pop ups. If they are inevitable and after you close them the login box opens,you may add the Close action to your code.

or Update your CITRIX receiver and see.


#15

Yeah everything is updated. Like I said, it only happens when I run it from Orchestrator. Checking with support desk right now.


#16

Don’t know if you have tried this, but “Launch Workflow Interactive” has saved me many hours of troubleshooting Orchestrator.

EDIT: Looks like I already suggested so disregard if you have tried this. Thanks!


#17

Yeah, I did try it. Thank you for the help again Clayton, and vvaidya.


#18

Hello Roman red,

I am facing the same issue now can you tell me how you got that issue fixed


#19

I am still having this issue. This was not resolved. My work around is to not use Citrix :confused: .


#20

Even I am facing same Issue now could you please help me how you resolved this issue