Robot Failing when running in Orchestrator - RemoteException wrapping System.IO.FileNotFoundException


After Migrating our processes to new Windows from Legacy, one of our processes are not able to run from our Robot PC through Orchestrator. The Process can be run from our developer PC, No problem, but as soon as it is activated from Orchestrator, we get the following issue:
Could not load file or assembly ‘0034_FinanceApprovalReminders, Culture=neutral, PublicKeyToken=null’. The system cannot find the file specified.

RemoteException wrapping System.IO.FileNotFoundException: Could not load file or assembly ‘0034_FinanceApprovalReminders, Culture=neutral, PublicKeyToken=null’. The system cannot find the file specified.
at System.Reflection.RuntimeAssembly.InternalLoad(ObjectHandleOnStack assemblyName, ObjectHandleOnStack requestingAssembly, StackCrawlMarkHandle stackMark, Boolean throwOnFileNotFound, ObjectHandleOnStack assemblyLoadContext, ObjectHandleOnStack retAssembly)
at System.Reflection.RuntimeAssembly.InternalLoad(AssemblyName assemblyName, RuntimeAssembly requestingAssembly, StackCrawlMark& stackMark, Boolean throwOnFileNotFound, AssemblyLoadContext assemblyLoadContext)
at System.Runtime.Loader.AssemblyLoadContext.LoadFromAssemblyName(AssemblyName assemblyName)
at UiPath.Executor.WorkflowLoader.GetWorkflowFromXamlPath(String assemblyName, String xamlPath)
at UiPath.Executor.WorkflowLoader.LoadWorkflow(String xamlPath, String compiledWorkflowAssemblyName)
at UiPath.Executor.WorkflowRuntime.Load(String workflowFile, String compiledWorkflowAssemblyName)
at UiPath.Executor.WorkflowRuntime.Load(String workflowFile)
at UiPath.Executor.RobotRunner.InitWorkflowApplication()
at UiPath.Executor.RobotRunner.ExecuteJob()

We have tried removing the nuget package and even restarted the Robot PC but the issue still persists. We thought it might be an issue with the namespaces of some of the old dependencies, but all references has been removed.
Any advice?

Best Regards,


As a lazy approach, we might be able to copy all the folders and files under %USERPROFILE%.nuget\packages in your dev PC to same folder of robot PC, to solve this matter. Can you try this?
(Please note that unnecessary files will be copied, too)


Hi @Mikkel_Bank_Henriksen_MIK

The error message mentions a RemoteException wrapping a System.IO.FileNotFoundException.

There could be several reasons for this error. Some possible causes are:

  1. The robot is trying to access a file that does not exist at the specified path. Make sure that the file exists and that the robot has the correct permissions to access it.
  2. The robot is trying to use an assembly or a library that is not available on the machine where it is running. Make sure that all necessary assemblies and libraries are available on the machine.
  3. There could be a problem with the UiPath runtime on the machine where the robot is running. Try repairing or reinstalling the UiPath runtime to see if that resolves the issue.
  4. The error could also be caused by a network issue or a problem with the connection between the robot and Orchestrator. Make sure that the network connection is stable and that the robot can communicate with Orchestrator.



Unfortunately did this not directly solve the issue, have tried to copy the files to the robot PC without any luck - it does however look like the robot might be trying to use a UiPath library which is failing due to migration.
The issue might be the one in this thread Database Connect Activity Broken when Migrating to Windows activity

Could this be the reason for the error?

Hi again,

it seems that the issue was caused by running the process on a robot PC which was not yet upgraded to newest UiPath version

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.