Robot execution not working

Good day

We have a situation were the following has happened.

We developed a package in our test environment and the package worked. Changed the file paths to use the live environment and when we publish to the robot and execute the robot fails. it tries to use the old test environment file paths. We have gone through the whole package and made sure there are no references to the test file paths but still fails when the robot executes. We even went so far as to check the code using notepad and it does not have any references to the old file paths.

Any help would be appreciated.


Are the paths hardcoded within workflow? Try running your code in a Debug mode and see which activity throws the error, Just in case you may still have missed the path somewhere.

Rammohan B.


There are some paths hard coded but have all been changed. After stepping through the workflow it was two database queries that do not reference the paths at all that were showing the errors, weird. After redoing them the process worked.

Thank you.

1 Like