Robot executing RDP, RDP won't connect if ran by robot

Hi,

I’m trying to create an RDP automation using uipath with remote runtime, but I’ve encountered a strange issue. The RDP won’t connect if the uipath started it (timeout), but it will connect if I connect it manually without using uipath. I’ve tried this multiple time and the behavior is always like this.

I’m executing command in run (windows + r) then type : ‘mstsc /v:192.168.125’ and lastly enter.

Any help or suggestion is appreciated. Thank you in advance.

Hello,

I just created and tested a sequence on my end multiple times. It works without any issues.

This is my package stack. Are any of your packages out of date?

image

Hi Andy,

My package is still default and I’m not adding anything, but the issue was fixed by rebooting both of the devices. Rebooting solved the issue, but I’m still not sure what is the root cause.

Thank your for your response :slight_smile:

Would’ve been nice to check the Task Manager to see if there was some abnormal CPU / Memory usage.

Maybe next time :wink:

Great that your issue is resolved👍