Robot disconnects after each job causing next pending job to fail

Normally if a job is in queue from orchestrator - it is supposed to show pending status and once previous job finishes, the queued job will start executing. But in my case,if there is a queued job, it will fail since the bot logs off and logs in again after each job. Each time it logs off , it shut downs the robot service which causes next job to fail immediately.
Note: I am using enterprise edition, Robots are in VDI’s. (There are multiple logins in same vdi based on each job -so bot is supposed to log off after each job, but it shouldnt get disconnected from robot. How can i make this happen ?)
What is the solution for this ?

Hi @iluildephonse,
All of your workflows are running using same robot and same “user” account?

Hi @Pablito No… i am using different user accounts for some of the process as well.

We use Robots in a couple of places running on Windows Server.

  1. Shared Jumpbox (VM) with RDS Host to allow more than two concurrent connections. End-users use Studio on this host and have provisioned developer/studio Robots, UiRobot is registered as a service.

  2. Several Robots (VM/AWS EC2) are configured with a 1:1 machine/robot ratio. A couple of robots are setup default (Login to the Console) and a few are set up to login Interactively. These Robots are provisioned as Production or Nonproduction.

  3. One host (VM) is set up in “High Density” mode with RDS Host, the robots provisioned are setup in Production and Non-production and set to Login Interactively.

I have not experienced how you are describing it of the UiRobot Service Stopping between jobs. For the very first run that is successful, what steps are you taking to start it? Can you verify that the UiRobot was registered as a service and not in user mode?

Can you provide the error message from the Job?


Hi @codemonkee,
This is the message i can see in job details when it faults.
"Job faulted due to service shutdown. "

I am able to see UiRobot as a service, but how can i make sure it is not in user mode ?

1 Like

If you see it in your Services, then it was registered as a service, maybe double-check that you don’t have multiple instances of UiPath installed?

Have you looked at your Windows Event Logs to see if there are any errors thrown by UiPath in the System and Application Logs?

1 Like

Hi @codemonkee, Yes it is registered as a service and no multiple instances.
I couldnt find anything related in windows event logs specifically related to robot service.

Hi, did you find a solution for this? We’re facing the same issue. Scheduling the robots with a break (5 min) in between is not an ideal solution.

It was VDI related configuration issue. Probably check with your IT team on it.
Our IT team was able to change the config, but I am not exactly sure which settings.


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.