Robot defaults greyed out when publishing

Hi, I have a problem. In my project when i try and publish robot default is greyed out. But when I make a test project with just a messagebox it works fine and I can select that option. Why would my project be greyed out for robot defaults? The project files itself are stored on a cloud. This is the community edition. Thanks for your help


this seems to be a library and not a project…

1 Like


When you are saying your project is graying out that means it’s fields (Custom URl, API Keys) are graying out?


wow youre right! i completely missed that. Is there any way to convert it to a project from a library without rebuilding it?

Just the option to use robot defaults

yes, just create a new project and copy/past the activities inside…

wish it was that easy. doesnt work. Also will need to copy all variables

Hello @mmimadi, you can convert a library to workflow via the .json file.
You can simple edit the “projectType:” property from Library to Workflow, then save the .json file and restart.