Robot created in Orchestrator not connected to Machine while acquiring licence for Community Version

First off, visit this topic(WORKAROUND: "Device ID already activated" error) to understand what I’m trying to do. The problem I’m having right now is that the robot created in Orchestrator is not connected to the machine as illustrated below



Hi, Am also facing similar kind issue while trying to obtain licence.

Please help me on the same

You actually have different problems:

Your robot is connected but if not defined in Orchestrator (You can tell this because it says robot unavailable)
Please go to Orchestrator > Robots page and add a robot for your machine

I’m guessing you have the enterprise version, right ?
Your robot service seems to not be started. It actually has a delayed start after windows restart so it doesn’t try to fight other services for resources. You can either wait a couple of minutes to start or go to services and try to start is yourself.
If the problem still persists, make sure you do not have both enterprise and community version installed.

1 Like

Forgive me for my ignorance but do you mean that I must create a robot for my local machine(in other words, my laptop)?

Yes, just go to robots page and click the “+” button > standard robot and then add the info in the fields .

Machine : your machine name, select it from the dropdown (NEC-200818FZ02)

Name : just a name

Domain\Username : add the domain and username OR, if it’s a local user, machinename\username

password : password for the user above


1 Like

Umm sorry, if that’s what you’re referring to, I’ve already created one that’s connected to the machine

I also tried deleting and creating a new robot for the machine but nothing changes.

I see, but the username has a weird format.
Do this:

  1. Go to your robot machine (laptop) and open a CMD
  2. Type whoami
  3. Copy that exact string in the domain\username field of the robot in orchestrator


So do I just copy the output over to the Domain/Username?

Yes, just modify your existing robot.

Wow it worked!! Thanks a lot!


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.