Robot behaves differently when remote desktop window is closed (element exists)

Hi all,

We are facing a very weird behavior. When we run a robot and start it from either orchestrator or the system tray on a virtual machine, and we are connected to the remote desktop through a UI session then the robot works fine. However, when we close the remote desktop window the robot does not work as expected. It fails on an if element exists activity. All steps before work (clicking, typing etc…) What could be causing this? We want to be able that the robot runs the same on the server without having to log on “physically” to see the session via the UI…

Edit: I tried to work with an “activate window”. This returns the error: “activate: could not find the UI element corresponding to the selector”. Why is the selector working on development machines and also on the VM when we open the remote desktop visually? It only breaks when the remote desktop session is closed and the robot works in background. It looks like the connection between the bot and the server stops working.

What is causing and what can be done to resolve this?

Thanks a lot!

Hi @krisvandenbergh,

have you tried to logout from the machine and login again, then trying to make in start without looking at it? Some VM go in lock screen when the user exit from them

Even when the remote desktop is not open, the bot fails… the issue does not seem to be dependent on this.

Have you tried to take a screenshot to check the status before the point tha fails?

Good suggestion! It seems the resolution of the screen is not okay… application does not fit.
We resolved it by updating the resolution in the robot settings.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.