Retry Scope is not working

Hi, I have used the retry scope activity, But it’s not working, credentials is right but still, it’s retrying, it’s not clicked the Login button.

For clicking login button alone try with send hot key activity with key as tab to get to that field and another send hot key with key as enter
Cheers @balkishan


It’s inserting the right credentials, but not clicking on the Login button. I have set 3 retry, but it’s keep retrying three times then the process goes failed. I have used in the right way.

May I know where it is getting failed inside the retry scope
Run in debug mode and let’s check that
Or if the click button is not working try with above suggested method

Cheers @balkishan

1 Like

Click Login is working fine, But it’s keep trying three times to insert the credentials.
Click Login I have used outside the Retry Scope activity. And in the condition I have used the Element Exist to check for the Next page element means after logged in.


Make sure that element exists activity inside the retry scope is used to check for element THAT APPEARS AFTER LOGGING IN
that is choose any element that appears once we logged in to the page

Cheers @balkishan

Exactly did the same bro, but it’s not working, username and password is correct, If I manually click login it’s working fine. But issue is bot is not clicking on the login button.

1 Like

If the retry scope is able to type into the field Then the issue is not with retry scope if not we need to check there
Kindly enable simulate click in click activity that clicks on login button And try once
Cheers @balkishan

1 Like

No bro, It’s not working, don’t understand what is the issue.
Tried after enabled the Simulate option in Click Login button activity.
It’s not Click on the Login button.

Is it typing the credentials in those fields

1 Like

Yes bro, It’s typing the credentials in username and password field. And the credentals is correct, But it’s not clicking on the Login button. It types the credentials three times after that the execution stopped bcz I set 3 in the Retry filed and gave the 00:00:02 second after each typing.

Please help to resolve this issue, it’s a small issue bro. for other process it’s working fine. But for this only it’s not working.

First thing we need to check is why it’s typing three times
—so the element exists activity is not looking for right element That is it should be chosen like when the type into activity types the credentials it should click on login button and then find any elements in that next page after logging in
—so put the click activity inside the retry scope activity next to type into activity and in Condition block choose a element that appears in the next page after logging in

Cheers @balkishan

1 Like

see bro, I put the Click Login after insert the unsername and password, still it’s not clicking on the Login button.

It’s typing three times username and password. after that the process got failed.

1 Like

Fine along with type into activity and it’s string out like this
“Your input string” + “[k(enter)]”

And make sure that sendwindowmessage property is enabled and simulate type it disabled
And remove the click activity next to type into activity
Cheers @balkishan

1 Like

I palani, sorry for the late reply, tried with the same method bro, it’s not working,
It is typing three times the credentials after that completed. It’s not clicking on the Login button.

Don’t understand why it’s not clicking on the Login button. If I remove the Retry Scope and use the same activity it’s working fine. But when I use the Retry Scope it’s not working.
@lakshman @Lahiru.Fernando

Palani… that’s a nice name :smiley: @Palaniyappan

Hey. have you tried using the simulate click instead of the send window message? Also after typing the password, can you try sending a hot key “Tab” to select the login button and then you can send another hot key “enter” to click the button

1 Like

Thanks Lahiru Bro,

can I use these outside the Retry Scope Activity. Means after typing the password use Tab and then use Enter send hot key.

Yeah… you can…

1 Like

Not working bro, don’t understand what is the issue.

It’s just typing three times in the credentials, it’s not clicking on the Logic, Used the Send Hotkey
even this are also not working.