Retrieving Arabic data from database

Hi Team,
I am reading data from oracle database and writing it into local file issue is that there is some Arabic data present in retrieved data and Arabic data appears as ‘???’ format. how can i Alter session language to get real data?

Thanks,

Hi @amit.chaudhary

Is your data coming as such, or is the target file not supporting the encoding? :slight_smile:

Hi @loginerror

Data coming as such, i have tried to write it into excel as well same ??? is appearing there also .

Just to be sure, could you run a debug session and inspect your data table via the Locals panel in Studio?

A screenshot of that would be helpful.

Even While inserting into the database using Execute non query - In the variables pane when I see…it’s showing as “??? ??? ??”

How to properly encode arabic characters to insert into Oracle DB

@loginerror

@amit.chaudhary Hey ,
I face the same Probelm.Did you solve this?

@amit.chaudhary
@loginerror
I too face the same error.Any help on this?

@amit.chaudhary @loginerror
I am facing the same problem. Can you please provide any update on the same?

@UiPathMaster @Stealth_Coder

Can someone help me on this. It is very urgent.

Hey @tapan_rath18 ,
I solved the error.
But could you pls brief where are you stuck at?
In the Insert query Phase?
thanks

@Stealth_Coder

I am facing the error while trying to fetch the data from the table.

it returns ??? ??? data from the database.

@tapan_rath18 ,

So while inserting itself it’s going as question marks or only while fetching?

@Stealth_Coder
I am not inserting data in db. I am only retrieving the data from db and in table, it contains arabic characters.

Please suggest how to get proper data from db.

Thanks

Can you view the database and re confirm whethere they are in arabic stored in DB?
Confirm.

thanks

@Stealth_Coder

Yes it is confirmed that the arabic is stored in DB. if you can please let me know how you have fixed, it will be very helpful.

Thanks

@tapan_rath18 ,
You need to follow this.: Setting the NLS_LANG Environment Variable for Oracle Databases

@Stealth_Coder

Mine is mysql, can you please help me on that as well.