Repository not being added to new project

I recently created a new project using the Windows Compatibility. After doing this I had to upgrade my object repository off the Windows Legacy version, I then added the upgraded repo into the new project. However the repo is not showing under the Object Repository section. It is being added to the dependencies. Not really sure where to go from here.


If you have upgraded your object repository from Windows Legacy to Windows Compatibility and added it to your new project, but it is not showing under the Object Repository section, there are a few things you can check:

  1. Verify the project compatibility: Ensure that the project itself is set to use the Windows Compatibility feature. To do this, go to the Project panel on the left-hand side in UiPath Studio, click on the “Project Settings” button (gear icon), and make sure the “Use Windows Compatibility” checkbox is checked.
  2. Check the folder structure: Confirm that you have placed the upgraded object repository files (.json or .xml files) in the correct location within your project’s folder structure. By default, the object repository files should be placed in the “Data” folder of your project. Make sure that the files are present in the correct location.
  3. Refresh the Object Repository section: In UiPath Studio, try refreshing the Object Repository section. Right-click on the Object Repository panel and select “Refresh” from the context menu. This will update the panel and display any changes or additions to the object repositories.
  4. Restart UiPath Studio: Sometimes, restarting UiPath Studio can resolve certain issues with the visibility of files or components. Close UiPath Studio completely and reopen it to see if the upgraded object repository appears in the Object Repository section.
  5. Import the object repository: If the upgraded object repository is still not showing up, you can try manually importing it into the project. Right-click on the Object Repository panel and select “Import” from the context menu. Navigate to the location where you have the upgraded object repository files and select them for import. This should add the object repository to the project and make it visible in the Object Repository section.
  1. I was unable to locate the “Use Windows Compatibility” checkbox in the settings, but the project is definitely a Windows project.
  2. There is no “data” folder from what I can find, I checked other projects I have as well and there were none in those either
  3. Refreshing the repo didn’t solve
  4. Restarting didn’t solve.
  5. the Import option doesn’t show in the Object Repository panel when right clicking.

I am able to create a project in Windows-Legacy and add the repository no problem. It shows no problem.

Hi @egillfisher

After adding the upgraded object repository to your project, try refreshing the dependencies.

If the above steps do not work, you can try re-importing the upgraded object repository into the project. Remove the existing object repository from the project dependencies and add it again. Make sure to select the correct file and confirm that it is added to the Object Repository section.