Renaming minor UIPath elements

ux
naming
learnability
studio
i_considering

#1

There are a few minor naming issues that can be confusing to new users. Let’s find some better alternatives

• Automatic recorder & Record
Most people would believe these two buttons do the following things:
Automatic recorder --> opens the recorder
Record --> start recording

In reality, it is the other way around. Furthermore, the Record button doesn’t actually start recording or the recorder, but a dropdown. So it’s a bit confusing.

Possible solution: rename the 2 buttons to:
Recorder --> opens the recording widget
Record --> the button that actually starts recording


• Read Cell / Write Value excel activities
WriteCell is a much more obvious and understandable name for writing into a cell.


Input Dialog vs. Message Box
Two elements (title and text) are called in 4 different way in the Input and Dialog activities:
title = caption
text = label

Title and Text should be used in both activities.


Type Into activity > add keystroke
The expected behaviour for a dropdown list is to choose a value for the current field.
The actual behaviour is that something is added to the string in the field.

Solution: Replace the downward arrow with a + sign


Attach to live element
This sounds almost scary :slight_smile: which is a shame since it can be quite useful.

Solution: not sure yet, requesting ideas

“Repair selector” might be a better option but not the best.
It’s not actually repairing the selector, and ppl might think that it will “fix” it, which is not exactly true.

It’s intended use is for elements that somehow change over time. It compares the current selector with the “new” one that you indicate, and tries to make a selector that works w both elements.

So, ideas?


#2

For the recorder I would have the first button as Recorder and the second as Start Recording to be 100% clear.

Agree Read Cell and Write Cell would be better as it’s consistent and same with Input vs Message Box

Can you elaborate on the Type Into Activity problem?

I am going to start a new thread re UiPath Explorer as there are a few things that could be improved.

Richard


The New UiExplorer
#3

Agree on all of them.

The Type activity change is minor: it’s about replacing the symbol that is to the right of the dropdown menu (currently a downward arrow), with a “+” sign, because it actually ADDS a special character to the current string. The arrow suggests a drop-down menu that normally replaces the editable field.


#4

Cormin, I would call the button Compare to Live Element

What do you say?

p.s. rest of the ideas, are spot on

Just, you have a typo , it’s Write Value / Write Cell , which should have the same name anyway.

P.s.s. Another naming inconsistency, the User Events wizard choices are not the same names as the activities in the Triggers category


#5

“Compare to Live Element” sounds good, maybe a bit too long. We’ll see if we can fit it. But something with “Compare” in it is a good idea.

Not sure what you mean by the Cell/Value typo. but just checked and this was recently implemented already.

I’ll check the User Events thing.


#6

:slight_smile:

“* Read Cell / Write Value* excel activities
WriteCell is a much more obvious and understandable name for writing into
a cell.”

This is what you wrote. I just think you meant Write Cell not Read Cell

Alexandru Dragoi - Senior RPA Consultant @UiPath


#7

Looks like a typo doesn’t it? :slight_smile: Well, it wasn’t.

Read Cell & Write Value were the names of the 2 activities used to read & write in a spreadsheet cell. But it’s fixed now to Read Cell & Write Cell.


#8

Well, it’s kind of the same, from a different point of view.

In UiPath there are two ways to access Excel, via Microsoft Office or
directly the file. Originally the activities were called Read Cell and
Write Cell for both methods.

In 2016 we added the functionality that Wrice Cell from Microsoft Interop
method can also write functions, not just text. This is why it changed to
Write Value and the other Write Cell remained with the same name.

So I thought you meant that the problem is we now have both Write Cell and
Write Value to do relatively same thing. So I was just seeing the same
confusion from other corner.

Anyway, I agree to change the names to be the same for both and more
uniform, but the hint in the Value field should be still indicating that
one Write Cell can write functions and one not.


#9

Stop fighting guys it’s not worth it! Do some more important stuff!! :grin:


#10

Do you call this fighting?

It’s not even a contradiction

Alex


#11

Another idea
In the Recorder, Open Application is called Start App and in the activities it’s Open Application