Removing column name when converting excel to text file

Hi Team,

Could you help to remove the column when converting excel to text file.
Column 0 is displaying which doesn’t require in my work flow.
Appreciate your help.Excel Header Issue.zip (7.6 KB)

1 Like

@RajeshT

Uncheck Add Headers option in Read Range activity properties and then check it.

Create a datatable with only the columns you need for your txt file

1 Like

Hi @lakshman ,

Am still getting the Column0 value.
image .

I have unchecked the Add headers option.

@RajeshT

Do one thing. Read data from next row onwards after header.

If it starts with A2 then mention Range in Read Range activity as "A2"

Hi @lakshman ,

Yes i tried by the way you have mentioned but still getting Column0 ,am not sure from where its coming.

@RajeshT

Could you please show me screenshot of your excel data and workflow. Will check and let you know.

Hi @lakshman

Here i have attached,


@RajeshT

Why you are reading two times here. Have you unchecked Add Headers in both Read Range activities ?

Hi @lakshman ,

Counting the rows for first time and Second time time adding those rows to output.
Yes both datatable,i have unchecked.

Appreciate if you provide new workflow which converting excel to text file.

@RajeshT

Currently i don’t have system.

You are converting DataTable into String right using Output DataTable activity. Could you please print that string and check once whether it’s showing that Column 0 or not.

And also mention Range like this: “D3:D100” and check it once.

Hi @lakshman,

I have checked Add Headers,and Range given from D2 now looks fine.
image

Thanks a ton @lakshman

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.