Remote Orchestrator

I have a trial version of the UiPath Orchestrator, Robot and Studio installed on a VM Server and they are working fine. I tried to install UiPath Robot and Studio on a laptop. When I look at UiPath Robot on the laptop, I see the message “Error connecting to Robot Service”. When I check the Orchestrator Setting of Robot, I see the machine name as the laptop name and cannot change it.

When I originally installed the software, I tried to activate a stand alone license.

When I reinstalled the software I tried to acquire the licence from the Orchestrator and received the following:
image
I tried to change the Orchestrator settings but could not.

Hi @drmai
Buddy you can better create a new machine with your machine name in VM and
tag that machine name to the robot you are using now
Cheers @drmai

I created a new machine in Orchestrator with the name of my laptop but that did not work. I am unable to change the Robot on my laptop to point to the URL of the Orchestrator.

Update: Yesterday,I was able to run a project from Studio, even though Robot couldn’t connect to the service. Today I cannot. I can’t have our business units developers reinstalling Robot and Studio every day. Is there an extra step that I need to perform or is this something to do with the Trial Version. Below is the message that I received. I checked the Robot service and it is running but the Robot cannot connect to it.
image


image

Hi @drmai

Could you please provide one screenshot of the Robot Orchestrator settings page from your PC as well as two more screenshots from Orchestrator from both Robots page and the Machines page.

This would help us clarify if all is setup correctly :slight_smile:

PC Robot Settings, everything is protected so I cannot change the machine name or enter the Orchestrator URL.

I would definitely try reinstalling Studio, you could follow this short guide here:


(first linked post in that post :slight_smile: )

Please make sure that the files were properly installed in that location and that no protection software/lack of permissions/firewall is in the way.

1 Like

Reinstalling Robot and Studio and accessing Robot first appears to have corrected my problem.

1 Like