Remote Copy paste issue

studio

#1

I am accessing my application which is on 3rd system.So to access this system I am accessing remote from my local system then again remotely accessing the 3rd system.My UI path flow chart works fine.But I am unable to copy paste the text field from my application to my local system.

Any solution?


#2

Hi there @Pratik_Vanjare,
Can you provide further information regarding the issue and what solutions you have attempted.

Generally, I would recommend using the ‘Send Hotkeys’ activity, using CTRL + C/CTRL + V.

If, however, you are unable to utilise hotkeys through your remote setup, another method will be necessary.

Thanks in advance,
Josh


#3

Hi Mr_JDavey,

I tried using ctrl+c/v. But it did not work. Ia m using ‘copy’ activity to copy text from remote. My process is inside a loop where the text is copied multiple times.It does work for max 2 time but later it gives an aggregate exception.


#4

Hi there @Pratik_Vanjare,
Interesting, it sounds like it could be a bug.

Though it’s not an ideal solution, it may be worth encompassing the ‘Copy Selected Text’ activity within a ‘Retry Scope’.

For the ‘Condition’, you can use an ‘IsTrue’ activity, based on the output of the ‘Copy Selected Text’.

For example:
String.IsNullOrWhiteSpace(strExtractedTextFromCopySelectedText)

You can then set the ‘NumberOfRetries’/‘RetryInterval’ as necessary.

Thanks,
Josh


#5

Hi @Mr_JDavey

I tried the above solution, but it did not work.Any other solution?


#6

Hi there @Pratik_Vanjare,
What exactly is being iterated through?

Would you be able to share the solution, or a snippet of it?

Thanks,
Josh


#7

Hi @Mr_JDavey,

The iteration is of a form from where I need to fetch data. It works fine for max 3 records but later it gives ‘aggregate exception’.

Thanks,
Pratik


#8

Hi there @Pratik_Vanjare,
From my understanding an Aggregate Exception is a container for when multiple exceptions occur concurrently.

Would you be able to log the Messages associated with the inner exceptions?

That way, we can try to determine why the exception is thrown.

Thanks,
Josh