Reframework - minimized exception screenshots (Maximize Window)

Hi guys,

i’m working on an SAP automation with the reframework.
During my automation the reframework takes exception screenshots and these look minmized to me. (Scroll Bars left and right at the corners of the window, so you can see that the window was mimized befor the exception screenshot was taken)
The Screenshots just contains just a part of the transaction window where the exception occurs not the whole window.

This leads to the question in my mind if my RPA automation is operating in an minmized window, and this is the reason why i just receive “minimized” exception screenshots. Or is it just how the take Screenshot activity is handeling screenshots?

The other weird thing is that some of the exceptions i received are explainable with the information that the window is minimized. E.g. i got selector Errors that are correct in the maximized window but have no object in the minimized window. Dynamic calculated operators like…: sap id=‘usr/lbl[16,+RowId.ToString+]’

I saw the activiy “Maximize Window” and now i am asking myself if uipath is operating in SAP by default in a mimized window so i have to maximize all the windows in SAP i want to operate in.

I hope someone can clear up my mind :)!


did you pass any selector in TakeScreenshot activity ??

Hi Krishna, thanks for the quick reply! :slight_smile:

Not at all it is just the plain “TakeScreenshot.xaml” of the Reframework.
Called by the SystemException in SetTransactionStatus.xaml.

My problem was caused by the screen resolution used on the execution server and its default server resolution.
The resolution i used unintended was 640×480 for the execution, but i developed this robot in 1.920 x 1.080 this caused many problems.

To fix this problem i used the orchestrator, here you can set for each robot the execution resoultion individually. (GoTo: Robots/Edit/Settings)

This finally solved a lot of problems for me.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.