REFramework - Get Client Security Hash - Restarting After 1st Transaction

I’m trying out the REFramework practice exercise ‘Get Client Security Hash’. I completed the Initialization and the Get Transaction Data stages. I didn’t create anything in the Process Transaction state as I just wanted to check if the system was successfully traversing the list of work items.

I am successfully able to open the applications, login, navigate to the relevant pages and extract the DataTable to be used as well as filtering it to the relevant work items.

However, when I run it, the process tries to reopen the applications after the first transaction.

I added a WriteLine activity to make sure the data was being filtered correctly. This is what the system log looks like:
output.txt (827 Bytes)

Looking at the REFramework process, this should happen only when ‘Process Transaction’ throws a System Exception. However, there is nothing in my Process Transaction state to throw an error.

This is what my ‘Get Next Transaction’ workflow is like:

Any ideas why this is happening and how to fix this?

Found the issue after debugging. I had not updated the argument list in Process Transaction. It was still expecting the TransactionItem to be a Queue Item. Updated it to DataRow and it worked.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.