REFramework : Assignment 1 : Get Asset Value: Column 'UiDemoPath' does not belong to table DataTable. Error

I am getting attached error in InitAllSettings file in Get Asset Value Section. Can someone please guide me here. I have used Asset Name as row(“UiDemoPath”).ToString

Please find attached screenshot and config file.Config.xlsx (19.9 KB)

Get Asset Value: Column ‘UiDemoPath’ does not belong to table DataTable.


I checked Assets sheet name in your config file and not found any asset named UiDemoPath. Because of that you are getting this error.

Its here, is this right ?

1 Like

UiDemoPath is a value in column “Name”, its not the column Name

To read assets use row(“Asset”).ToString

I am getting this error if I use row(“Asset”).ToString
Get Asset Value: Invalid asset type was specified for asset ‘{0}’.

Have you added Asset in Orchestrator. What is type of Asset ?

You have to use row("UIDempPath").ToString

@Sreelatha278 meant you have to use Asset Name not Asset in the expression.

Karthik Byggari


UiDemoPath - Type Credential

Yeah, that was my understanding too. Not sure if its right though.

then use Get credential Activity instead of Get Asset

1 Like

Do you have working InitAllSettings file ?

to get that value UiDemoPath, we have to use row(“Coulmn Name”). Here the column name is Asset in Config file.

Do one thing,
Move Name and Value (UIDemoPath) present in the Assets tab to Settings tab in the config excel file.

And use Get Credentials activity, and pass the value as in_Config("UIDemoPath").ToString

Karthik Byggari

Just checked the Config.xlsx attached.

UiDemoPath is mentioned in both Settings and Assets sheet.

I believe you are using the ReFramework.
Please remove it from the Asset sheet and test first.
Once it works create an asset in the orchestrator (Type: text not credential). Remove the UiDemoPath from the Settings sheet and add it to the Asset sheet and try again.

This worked. Thanks Sowmya.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.