Hello guy,
i designed a process in which rpa read blank remark column,

Remarks will be added after each transaction in the blank remark column itself.

So RPA should not run if the remark column are full (It should show no data to proccess).

but when i run the process it is taking input even though all remark columns are filled.

so does anyone have the solution for this.


After reading the data filter the datatable on remarks column empty …then check the count…if count is zero all are processed else need to process those items


Hi @Gokul_Murali - Alternative way is you can do with Assign activity

Variable of type Int Count = DT.AsEnumerable.Where(Function(x) String.IsNullOrEmpty(x(0).ToString)).Count
  • DT is your data table name
  • x(0) represents column index, here I’ve assumed first column so given as 0, let’s say if it is 5th column then it is x(4)

The above exp returns the empty values count in a column. If it is 0, means there were no empty values, >0 means empty values exists

So, you can take a IF, Count = 0

>> You can skip processing since there were no empty values in the Remarks col

>> Start processing, as the empty values exists in the Remarks col

hi @Gokul_Murali

In the initialization when you’re reading the data from your input source,
right after reading the data please use a filter data table activity to keep the rows with Remark Column and condition as is Empty.

that would resolve the issue.


@adiijaiin To remove the column containing data,

Data in the remarks column is not fixed it can be “Success”, “Failed”," Moved".

So how can i give all the possible values in the filter data table activity to remove it.

Hi @Gokul_Murali

You just need the rows with Remark column as blank, right.
In filterDataTable you can use something like this

Please do it like this, and it’ll work.

Happy Automation!


I tried this

Input file “Comments” column nothing is empty.

MicrosoftTeams-image (23)

So the value should be zero right, instead of that it is showing 4 (either data is there or not in “Comments”) column it is returning value=4

Thank you so much,

I made a slight change in what you told.

1 Like

Great that it worked with lil changes :stuck_out_tongue:

1 Like

@Gokul_Murali - It looks like you have given wrong column index. x(0) means bot look at the first column and gives the result. May be that could be the reason everytime it gives the value as 4. But according to your input excel comments should be last column. So, you’ve to change column index accordingly.

Ex: Assume in your input excel, comments column is 6th position, then in data table it has to be x(5) as the data table column starts with index 0. First colu index 0, 2nd col index 1…

No worries. Try this tip from next time :slight_smile:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.