Reading Bot's Log File Whilst in Interactive Session

robot
studio
uipath

#1

So, the problem is that the bot reads it’s own log file to try and find a particular log message and extract an id number. This works just fine when run manually or in session 0 via a normal launch workflow. Please don’t ask why the bot is doing it this way and not just using variables, I don’t know. it’s a piece of legacy code and it’s just the way it is.

The problem comes when trying to launch the process in it’s own session. - The code returns an “Unexpected Process Termination” error.

I am assuming it’s some sort of credentials issue where the bot doesn’t have permission to access the file. I tried launching UiPath Studio as both an admin and a normal user, and the plain read text file worked both times.

I am assuming the issue lies somewhere the nature of the credentials and switching the session control. Does UiPath lock the log files when running interactively?

The issue came to light when upgrading from 2016 to 2018, so it may have something to do with that.

If anyone could shed some light on the issue, or propose a solution, I would be most grateful
I am looking at the possibility of rewriting the code so it doesn’t go anywhere near the log file, but I am hesitant to add another patch to what is already a messy piece of code.