Read range inside application scope with using filters fails

I think I have problem in excel.

I copied all the data into new excel file. I didn’t get any error


oh, ok. yes, sometimes we see issues generated by improper excel files.


Referring to the image and comparing with my XAML.

I don’t have table.
I am not using filter.

Inside Excel application Scope
Read Range with no range set.

Before this error- I got this “pc ran into error taking sometime to fix errors”.

Again I am getting the error

ok, please send me the repro steps and the excel file you are testing with. you don`t need to send the whole file, just a small piece where the issue still happens. you can change the sensitive data inside to fake data

1 Like

Step1 : Reading Excel 1
Step2: Adding new column between
Step3: writing the value to column
Step4: appending to other excel

Is it due to excel file is not saving properly ?

Have the same problem. Process worked for months now and yesterday it decided to trow this error and cant get pass it

Did you do an upgrade of the excel package when this started to happen?

Dont think so…Error occured yestreday…How can I make an update?

Hi @Petar_Soce,
Like this.


Will try and let you know, thank you


Already have everything on autoupdate, and all of the packages are updated

Send me please the wf to repro and also the excel file. I will investigate.

The file was corrupted, meaning it had a wrong date format in one of the cells and the robot could not read it.

I’m facing the same issue. For me however the Read Range was working well till last week, on the same file. I used a Parseexact to get date from another file, and that was the only change I did in the code and since then I’m facing this issue. I tried both Scope read range and Workbook read range. Both gives me errors, different though. Please see below the error messages.

Application scope Read Range

Workbook Read Range

As @Iruths mentioned I’m getting some cells as ##### in the excel. When I tried to read the range which doesn’t have the # symbol, it worked.

As this was working perfectly I’m not sure what could have gone wrong. Will changing the Culture format solve the issue? I tried to changing to few formats, but it’s the same.

Hello, i had the same problem

For those who have this problem and might be looking for a solution:
I had the same problem. There was a cell that contained “############################”. If that was removed it worked for me…


I am not allowed to modify the date. How can I fix it ?

Please change the cell format to date by right click on the cell.There will be a option that format cells and then choose date
Hope this will solve your issue

I had this same issue and was able to solve it. The solution was that the columns format are not correct. So, i edited the excel file before running the file with UiPath. Columns with date was changed to SHORT DATE. Columns with amount was changed to NUMBER format and every other columns. I hope this helps though.