Read Range - INSERT db Error Unexplained

Hi to all,
today, unexpectedly I get an error trying to insert a table on DB.
An operation that I generally do normally.
The error I see is this:

“Insert: ERROR [42000] [MySQL][ODBC 5.3(w) Driver][mysqld-8.0.22]You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ‘DEFAULT VALUES’ at line 1”

The start begins by reading an xlsx file.
File has header columns with no spaces.
The data in the columns is alphanumeric.

In my flow, I do a READ RANGE and create an IMPORT table.
Then I use uipath’s INSERT command, and hence the error.
image

What’s wrong? I do not understand!

Hi,

Could you pls double check on the column names in the excel with data table you created in mysql DB. thanks.

Column Name File are identical to Column Name on DB.

Hi,

just one thought. may be the column NumeroRiga doenot have any data thats what creating issue while using inert activity. i also could see you already allowed null for all the columns but just try adding some content to the NUmeroRiga column in the excel and try and also format the c column to the left and try running the activity. thanks.

@AaronMark

In IdDocumento first line data is valid? because below data don’t have the -328612

Hope this may help you

Thanks

OMG I have tried all of this.
I have renamed the columns with A, B, C, D, E, F and the same on DB.
I removed Line 1 from the file.
I have entered a numbering in the “empty” column.
I ran a test, but always with the same error.
This is so absurd!

I try to attach my script because I don’t understand what is wrong.

rpa_doxee.xaml (44,7 KB)
ESEMPIO.xlsx (11,5 KB)

Hi everyone,
I found the solution by myself.
I noticed a different version of the Database Activities package, apparently not compatible with my version of Uipath!
I have installed the previous version, 1.4.0 and everything is working fine now.

Thanks to everyone anyway for your support, always ready to help inexperienced people like me.
Aaron

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.