Read range does not work when Excel sheet is protected

I’m trying to use Read Range activity. It works as expected when I don’t protect the Excel file. But when I protect the worksheet (w/ no password), then Read Range activity fails with an error message. Has anyone faced the same issue? Protect was implemented onto “worksheet” only, not “file”. I thought I need to unprotect the sheet before doing Read Range, but I’m not sure how I can achieve it. I appreciate very much if anyone could give me a suggestion.

Are you using the Read Range activity in excel application scope?

Have you tried using the “Read Range” from workbook activities? This does not display a copy of the Excel Workbook usually so maybe that will circumvent it?

1 Like

Thank you!!! It resolved.

Yes, I was using Read Range under Excel Application Scope. But when I used workbook Read Range, it worked !

Thank you so much for your advice.

Hi @cotly

Even I faced the same issue, but workbook read range is taking lot of time. (3+ mins for reading).
Is there any other way that we can read the protected sheet.

I’m surprised to here that activity is taking longer as it’s normally much quicker. As with anything it depends on file size and activity. It’s also worth noting that my advice here is based on the software over a year ago so there may be other methods now available.

There’s some custom activities that have been built above and these allow you to toggle the protection.

1 Like