Read range activity can't extract Excel data to the end

Hello,

During the activity of saving the data in the data table using “read range”, I found that “read range” was not reading all of the Excel data. The data is only read to the middle and stored in the data table, but no errors occur and the process ends normally. How can I solve this?

Best regards

Do you have a specified range or do you read the entire sheet?

@jinjin - Could you please show us the screen shot of your read range? Also, let us know what is total # of rows in your input.

So far, i have tried reading 40K rows and it worked without any issues.

yes! Read range is inserted in the Excel application scope and enter both sheet name and range.
activity

I attached the image to the answer below.

Do you have blank lines in this file?

i have blank lines like this

Could you please share a sample file with which you have a problem?

I’m new user so I can’t upload attachment :sob:
so I upload my test file to google drive!
this is my link https://drive.google.com/file/d/1dCkLRqULRrHjS19gHwYTBZzpwlarR0DC/view?usp=sharing

The data corresponding to the 18th line of Excel is brought to the middle and the data below is not being read.

Hmm. I have read all 24 rows and 45 columns.
Can You check yours output with mine?
TEST.xlsx (13,7 KB) output.zip (762 bajty)

Look at UiPath:
image

Escel scope properies:
image

Read Range properies:
image