Read pdf not working?

Hello All,

I’m trying to simply extract data from an already OCRed PDF file and I’m having some troubles. At the moment I’m using read pdf text-append text-text exists. My goal is to read the pdf text contents, write it to a word file (or text file, whichever works better), than check if it contains specific content. When I run this, It seems to read the pdf forever and never actually finishes. The other day I ran it then went out for a 30 minute walk and came back and it was still running, no error messages or anything. The PDF isn’t that big as well, it’s only one page. Anyone know why this is happening?

@Evan123 - Please share the screenshot of the workflow?
Also, make sure you have Reading Enabled on the pdf.

I am also not sure if the text exists is the right activity so I will not include it in the ss

After the read pdf text , try print the output variable in write line and comment the append text.

Hi @Evan123,

Try to debug the sequence and let us know which activity is executing forever.

and also the second activity is normal append line activity or you get it from other packages?

I’m not sure how you see that? I didn’t get any message saying which activity was running. The second activity is the append text from the word activities.

Ok I’ve just tried this. And now I see that it’s reading the pdf over and over again? It fully reads it, then just countues without stopping? hmm

Another thing to note is that I just tried the exact same sequence with another pdf with some lorem ibsum, and it works perfectly and takes 1 or 2 seconds. So maybe it’s just the pdf itself? but either way how else would I get around this…

@Evan123 - is it possible to share that pdf in question?

No, sorry. It has sensitive information.

@Evan123 - When you open the pdf , are you seeing “Secured” on top? like this


No I’m not

Check UIPath.pdf activities are updated to the latest version or not
and if yes, try to execute any other sample pdf and let us know its behaviour.

If you are looking for specific content then RegEx’s might work.