Read CSV activity returns box characters

Hi All,

I am trying to read a csv file (pipe delimited) and it returns me this output:

image

Can someone help me to fix this? Thanks.

1 Like

@jomsamago Did you convert the OutPut DataTable to String ?

cheers :smiley:

Happy learning :smiley:

2 Likes

Yes. I’ve also tried to print it using for each row, still the same output. Although, it’s very weird in for each row because the values are only located in the first column.

1 Like

Can you send me your sample csv file ill try to investigate.

@jomsamago

3 Likes

@jomsamago
Excel file has English words or other languages??
If other languages then you should change language property of Excel activity in property panel

1 Like

Nope. Only English language.

I’ll rename the file to .xls so it could be shared here. Convert it to .csv after download. csvbox.xls (224.0 KB)

In datatable I have one column in which there are many values like 5.502333 etc… I just want to take round of value like 5.50 till two digit … how I can apply for all values in datatable…

Need ur Help!!

Not sure if you’re in the right thread mate. But you can do this:

For each row
Assign: row(ColumnName) = row().ToString(“F2”)

Cheers.

But I want to take round off values how can I do that!!

Why not the csv files ?
We need the original files for reflecation purposes!

@jomsamago

3 Likes

No. You don’t understand. The UiPath does not allow .csv file format. See photo below:

The file I sent is still the csv file I’m talking about, I just renamed it to .xls so that it can be uploaded here. Hope everything is clear. Thanks.

If that the case you can put the files to folder and zip it make sense!
@jomsamago

3 Likes

I don’t know what’s the difference. You just have to rename it after download. :sweat_smile::sweat_smile: Anyways, here you go. WorkOrders2019-10-03 151702 - Copy.zip (25.4 KB)