Read CSV activity issue if first row is blank

Hi, I am trying to read csv in which first row is blank. UiPath throws error in this case “CSV format is invalid”. I have found on forum that this is read csv activity issue that it dont consider this type of file as csv.

But I just want to read that csv add 1 column and upload it somewhere.
Can anyone please help me finding workaround for this.

Thanks in advance,
Mohini N.

hello @mohininemade301094

have you disabled the include column names property and tried to extract ?

if not try it might work .

Regards
Ajay

yes it is checked ! same settings as you have shown.

@mohininemade301094

uncheck it and try

Hi @mohininemade301094 ,

mention the range in the read range activity and try it. if you still face the issue can you share the input file and workflow if possible.

Thanks

1 Like

@Jyotika_Halai

i am not facing any issue :stuck_out_tongue_winking_eye::stuck_out_tongue_winking_eye:

Kindly share that csv file if possible
Even a sample would be better
Cheers @mohininemade301094

Same!!

read csv activity doesnt have range to mention.
File is confidential ! But for ref.
image

file has data in this way. First row first column is blank.
I just tried on another machine and it worked. but not working on machine on which I was trying from first !

@mohininemade301094

use read excel activity inside excel scope to mention the range and read csv

Okay let me check with !

Not able to do this. File type is csv and not excel.

Can you share the XAML file?

Hi @mohininemade301094

Please check below screenshot

Can you share it in a text editor instead of in excel? Excel will change the format, so it is better to see the actual CSV the same way uipath will read it. Feel free to blank out information as needed as long as structure can be seen

This will write file in xlsx format, which is not acceptable where I ll be uploading file. I want it to be in csv only. Also i tried reading it using read text file activity. I am using write line to see data but nothing happens.

Thanks

Here is sample xaml with csv.

SampleCSV and XAML.zip (1.8 KB)
Working on my machine. But not on other. what can be issue ?
Note: excel activities package is updated. UiPath versions are same on both machines.