RE Framework Assignment one issue

Hello Team,

I have a question regarding RE framework assignment , after debugging in output error shows, please guide me how to resolve this issue

thank you
Kavita

Hey,
it’s looks like one of your column name is incorrect.
Please check if there is any space in Type column.
If it still doesn’t work can you share how your datatable looks like and content of the activity which make the error ?

Continuing the discussion from RE Framework Assignment one issue:

thank you for quick response :slightly_smiling_face:

Hi @Kavi_Patil

Still facing any issue on this?

Thank you.

yes can you help me please

Can you please share the expression in Assign activity and your DataTable column name?

In Debug mode, go to locals panel, get the DataTable screenshot.

Thank you.

Hi @Kavi_Patil

Looks like the column “Type” is either not present in your DataTable ‘dt_TransactionData’ or incorrectly entered in the column name in the Assign activity.

Additionally, the expression can be change as below.

It should be like dt_TransactionData.Select("[Type] =‘WI5’ AND [Status]=‘Open’").CopyToDataTable

Note: LHS variable type should be DataTable which used in the assign activity.

Thank you.

[quote=“Jobin_Joy, post:11, topic:379534”]
Looks like the column “Type” is either not present in your DataTable ‘dt_TransactionData’
How to fix this issue
i tried by changing the assign expression after debugging its showing same error

Hi!

can you try like this if that column name already inside your Dt. that might be space after or before your column name Type or Status. so this query will remove the white spaces

dt_TransactionData.Select(“Type='W15” AND Status=‘Open’").Trim

Regards,
NaNi

Can you please share your xaml here to check in detail?

Hi @Kavi_Patil

The below one is working fine for me,

image

Can you please check the same? Thank you.

Hi,

Based on the screenshot of the locals panel you are not getting any data in the data table dt_TransactionData and it is showing empty. Could you please check your out argument of this data table and also check if you have any data table with the same name in your variables section.

check your data table dt_TransactionData if it is having data or not by using the following expression. dt_TransactionData.rows.count

thanks.