Queue item and datarow mismatch of arguments

in get transactiondata workflow error with arguments like if i change queue item to datarow and iotransactiondata to datatable it is throwing errors

@Jebarohith19 When You change the Data Type of a variable, and if that variable is used again somewhere in the Other Parts of the Workflow, You’ll need to change the Datatype of those Variables or Handle that part as well.

Changing a Datatype of a Variable which has already been used in Several other places in the Workflows requires Attention of Changing the way it is used :sweat_smile:


i have changed in the workflow and i cudnt find anywhere else in the workflow.

@Jebarohith19 Can you Check this link and see to it if the Changes are done properly as mentioned :


i have done already what is told in this post removing “nothing” and doing it

as u can see it is throwing errors in the importing arguments

@Jebarohith19 You have not Change the Type of TransactionItem in Variable Section :sweat_smile:

actually it worked but now a new error and i cannot find error inside the workflow but it is simply throwing one or mor echildren has warnings

@Jebarohith19 Can you Show me your Variable Section ?

now this is in process transaction error in same transaction item

@Jebarohith19, If you see such error:

Step 1: Go to the workflow and change DataType in the argument panel (as appropriate) and Save it.
Step 2: Click on Import Argument and change the datatype so that it match with what we have declared in workflow.



i have updated all the arguments as u can see but still login.xaml (8.7 KB) Main.xaml (53.5 KB) errors are there.

In this screenshot, it suggests that DataType of in_TransactionItem in Process.xaml is DataRow however while invoking workflow you have selected QueueItem.

1 Like

@Jebarohith19 Yes, You need to Change the Datatype in Process Workflow Arguments :sweat_smile:


yah that worked buddy @supermanPunch

1 Like

yeah got it now thanks @Bhavik_Solanki

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.