Question Advanced Training Assignment 2 - Report Year 2017 or 2016?

@siddharth996 @PrankurJoshi

hi guys i was looking through this thread as i felt lt is simialr to an issue i am facing in the same assignment .

i am extracting the structure data in the ‘init state’.
trying to take it out through a workflow and then taking it to the Get transaction state.
because of this i am getring an error while passing it through Xaml files.

but Sid , i see that you are doing the extraction and filter wverytibh in the get transaction state. so essentialy you are not passing any data table as arguments .

is that allowed in the sheet assignment because as per the sheet they have mentioned to extract the data table through arguments .

Sid , did you favmce any similar issue while passing data table through workflow etc etc.??

Thank you Prankur. I will try to implement this.

Best Regards,


Hi dennis,

I have used all the output arguements for the extraction data rows. As i was facing the issue at the selector of the Element Exists for the page loop, I couldn’t see the output of the extracted data row in the Init state.

Thanks & Regards,


Hello everyone, I am sorry but can´t find out why do I still get 0/100.
If I press the “Reply” button at the assignment that failed, is anybody going to reply to that?
Thank you.

Its an automated evaluation system. Please verify completed records and Upload ID and follow this

  1. Reset Test Data
  2. Clear Queue in the Orchestrator
  3. Run Dispatcher
  4. Run performer
  5. Submit your ZIP file

Hello prankurjoshi.
I did what you mentioned above, but still, the result is 0/100.
I think all my outputs are correct, please see the pic.

I too have same problem .
I tried and upload it for 20 times.
But still could not find reason for that.
Share the solution for the problem if u get one plz.

Even though I changed the input as a video, I still have 0/100. I think I used all my options.
If anyone could have a look and maybe you will find a reason. Cheers.

Please resolve any exception you are facing


@PrankurJoshi Cheers for an advice, but the exception was handled by the retry feature.
Even though before it was with no exceptions, I still got 0/100 (but didn´t record the screen)
As well if this is why it failed, I would expect something like 80/100 but not 0/100.
Thank you

okay great, that was worth a try

In comments section, please write only the Upload ID. No need to mention “Uploaded with ID XXXXXX”

1 Like

Hi , I am facing similar problem as well where the in_WIList.Count.ToString when printed in the GetTransaction workflow turns out to be null.
So the issue seems array data not getting passed from the System1_ExtractData workflow to the GetTransaction. Please help.

Have done below:

  1. Created WIList variable of DataRow type in Main-Init section
  2. Created OUT argument in_WIList in System1_ExtractData to get the Datatable value in Datarow using the select query to filter Type=WI5 and type as Open
  3. On invocation of Get Transaction Data workflow , passed the arguments in_WIList with IN type and setting its value as (WIList - the init variable)

Still GetTransaction Data workflow is not getting the Datarow array data. Hence I am stuck since long. please help.

Please verify in Init State that you are getting rows in Extracted Table, if yes then have you sent that DataTable or Filtered Data Row array to get transaction data via arguments.


Hi , Yes in the init state the System1_ExtractData Workflow is giving me the results of the row count as 16. Also the this datarow in_WIList is passed to the GenerateData Workflow as argument, bt on printing found data is not getting received.
Please find the images attached to help understand my setup.

“message”: “Assign Transaction item: Index was outside the bounds of the array.”,
“level”: “Error”,
“logType”: “Default”,
“timeStamp”: “17:14:53”,
“processVersion”: “”,
“jobId”: “4e6a8723-61be-4195-9b54-f6df661a4d91”,
“robotName”: “NAM\RPEERANNAW001”,
“machineId”: 0,
“fileName”: “GetTransactionData”,
“logF_BusinessProcessName”: “Framework”

“message”: “Error getting transaction data for Transaction Number: . Index was outside the bounds of the array. at Source: Assign Transaction item”,
“level”: “Fatal”,
“logType”: “User”,
“timeStamp”: “17:14:53”,
“processVersion”: “”,
“jobId”: “4e6a8723-61be-4195-9b54-f6df661a4d91”,
“robotName”: “NAM\RPEERANNAW001”,
“machineId”: 0,
“fileName”: “Main”,
“logF_BusinessProcessName”: “Framework”

Not sure how to resolve this issue


want was the fix , to your issue i have doing now even i am facing the same issue which you faced but do in need to change 2017 or 2018, since current year is 2019


I am having the similar issue . I have tried both 2017 and 2018. the process runs fully end to end but I am still getting 0/100.
Please refer to the discussion board and provide feedback.
That would be helpful.
Generate Yearly Report for Vendor Assignment - #25 by SHasan
thank you

@ovi @learn_uipth @PrankurJoshi
need a fix in the testing environment by uipath team.

Sorry, yesterday I cleared the advance level by having 2018 has the fix